Une fois qu'une VM à apprentissage profond est déployée dans VMware Private AI Foundation with NVIDIA, l'état du pilote invité NVIDIA vGPU devient sans licence.
Problème
Le fichier /var/log/vgpu-install.log contient l'un des messages suivants :
État de la licence : sans licence
Sans licence (restreint)
Cause
vgpu-license
ou à l'assistant de configuration du catalogue pour Private AI dans
VMware Aria Automation n'est pas valide, a expiré ou n'est pas correctement formaté.
Solution
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Vérifiez la validité du jeton de configuration du client.
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Vérifiez que la licence vGPU est correctement formatée et suit le format de jeton JWT, qui ressemble généralement à
eyxxxx.eyxxxxx.xxxxx
.Vous pouvez décoder le jeton JWT à jwt.io pour vérifier la date d'expiration et l'URL du serveur de nœud.
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Le jeton de licence vGPU est également enregistré dans /etc/nvidia/ClientConfigToken/client_configuration_token.tok.
- Pour résoudre le problème, exécutez cette commande pour rechercher des messages d'erreur spécifiques liés à la communication avec le dispositif NVIDIA License Server.
cat /var/log/syslog | grep -i nvidia
- Remplacez le contenu du fichier /etc/nvidia/ClientConfigToken/client_configuration_token.tok par un nouveau jeton, exécutez la commande suivante :
echo -n $vgpu_license_token > /etc/nvidia/ClientConfigToken/client_configuration_token.tok
- Redémarrez le service NVIDIA.
/etc/init.d/nvidia-gridd restart
- Vérifiez l'état de la licence du pilote invité NVIDIA vGPU.
nvidia-smi -q | grep -i "license status" | sed 's/^[ \t]*//'