Un serveur de sécurité peut ne pas fonctionner s’il n’a pas pu être couplé correctement à une instance du Serveur de connexion.

Problème

Les problèmes de serveur de sécurité suivants peuvent apparaître si un serveur de sécurité ne peut pas être couplé au Serveur de connexion :

  • Lorsque vous essayez d’installer le serveur de sécurité une deuxième fois, il ne peut pas se connecter au Serveur de connexion.
  • Horizon Client ne peut pas se connecter à Horizon 7. Le message d'erreur suivant s'affiche : Échec l’authentification du Serveur de connexion View Aucune passerelle n'est disponible pour fournir une connexion sécurisée à un poste de travail. Contactez votre administrateur réseau.
  • Le serveur de sécurité s'affiche dans le tableau de bord d’Horizon Administrator comme étant arrêté.

Cause

Ce problème peut se produire si vous avez commencé à installer un serveur de sécurité et que la tentative a été annulée ou bien interrompue après que vous avez entré un mot de passe de couplage de serveur de sécurité.

Solution

Si vous prévoyez de conserver le serveur de sécurité dans votre environnement Horizon 7, procédez comme suit :

  1. Dans Horizon Administrator, sélectionnez Configuration de View > Serveurs.
  2. Dans l'onglet Serveurs de sécurité, sélectionnez un serveur de sécurité, sélectionnez Préparer la mise à niveau ou la réinstallation dans le menu déroulant Plus de commandes, puis cliquez sur OK.
  3. Dans l’onglet Serveurs de connexion, sélectionnez l'instance du Serveur de connexion à associer au serveur de sécurité, sélectionnez Spécifier un mot de passe de couplage de serveur de sécurité dans le menu déroulant Plus de commandes, tapez un mot de passe, puis cliquez sur OK.
  4. Installez de nouveau le serveur de sécurité.

Si vous prévoyez de supprimer l'entrée du serveur de sécurité de votre environnement Horizon 7, exécutez la commande vdmadmin -S.

Par exemple, vdmadmin -S -r -s security_server_name