Lorsque vous effectuez la mise à niveau du service View Composer avec le programme d'installation de View Composer ou que vous exécutez la commande SviConfig databaseupgrade, l'opération peut ne pas réussir à mettre à niveau la base de données View Composer.

Problème

L'opération SviConfig databaseupgrade affiche le code d'erreur 17 ou le programme d'installation de View Composer affiche un message d'avertissement.

Database upgrade completed with warnings

Cause

Le logiciel de mise à niveau de la base de données contacte vCenter Server pour obtenir des données supplémentaires sur les postes de travail. La mise à niveau de la base de données peut échouer si les postes de travail ne sont pas disponibles, si l'hôte ESXi n'est pas en cours d'exécution ou si vCenter Server n'est pas disponible.

Solution

  1. Pour plus d'informations, consultez le fichier journal SviConfig de View Composer.
    L'emplacement par défaut de ce fichier est C:\Users\All Users\VMware\View Composer\vmware-sviconfig.log. Le script de mise à niveau journalise un message pour chaque échec.
  2. Examinez les enregistrements du journal pour identifier les postes de travail qui n'ont pas pu se mettre à niveau.
    Option Action
    Le poste de travail existe mais n'est pas disponible. Rendez le poste de travail de nouveau disponible.

    En fonction de la cause de l'échec, vous pouvez avoir à redémarrer l'hôte ESXi ou vCenter Server ou à exécuter une autre action.

    Le poste de travail n'existe pas. Ignorez le message de journal.
    Note : Un poste de travail supprimé peut sembler exister dans Horizon Administrator si un administrateur supprime la machine virtuelle de poste de travail directement dans vSphere.
  3. Exécutez de nouveau la commande SviConfig databaseupgrade.