Vous pouvez corriger une recomposition qui a échoué. Vous pouvez également agir si vous recomposez accidentellement des clones liés en utilisant une image de base différente de celle que vous vouliez utiliser.

Problème

L'état des machines virtuelles est erroné ou périmé suite de l'échec d'une recomposition.

Cause

Une panne du système ou un problème s'est peut-être produit sur l'hôte de vCenter Server, dans vCenter Server ou sur un magasin de données lors de la recomposition.

La recomposition peut également avoir utilisé un snapshot de machine virtuelle avec un système d'exploitation différent du système d'exploitation de la machine virtuelle parente d'origine. Par exemple, vous pouvez avoir utilisé un snapshot de Windows 8 pour recomposer des clones liés de Windows 7.

Solution

  1. Sélectionnez le snapshot utilisé dans la dernière recomposition réussie.
    Vous pouvez également sélectionner un nouveau snapshot pour mettre à jour les clones liés vers un nouvel état.

    Le snapshot doit utiliser le même système d'exploitation que le snapshot de la machine virtuelle parente d'origine.

  2. Recomposez de nouveau le pool de postes de travail.

    Horizon Composer crée une image de base depuis le snapshot et recrée les disques du système d'exploitation de clone lié.

    Les disques persistants d'Horizon Composer qui contiennent des données et des paramètres d'utilisateur sont conservés lors de la recomposition.

    En fonction des conditions de la recomposition incorrecte, vous devrez peut-être actualiser ou rééquilibrer les clones liés à la place ou en plus de les recomposer.

    Note : Si vous ne configurez pas les disques persistants d' Horizon Composer, toutes les recompositions suppriment les modifications générées par l'utilisateur dans les machines virtuelles de clone lié.