Même si vous avez suivi la procédure pour éviter les problèmes de Microsoft Sysprep lors de la conversion de votre VM d'image en image publiée, la tâche de conversion expire dans une tentative ultérieure.

Problème

Lors de la première tentative de publication de l'image, sur la page Activité, vous observez l'échec du processus de conversion d'image avec une erreur d'expiration en raison de problèmes de Microsoft Sysprep liés aux packages appx. Après avoir suivi les étapes d'optimisation décrites dans la section Personnaliser le système d'exploitation Windows de la VM importée et résolu les problèmes décrits dans les journaux d'erreurs de Microsoft Sysprep, essayez de convertir l'image. Lors de cette deuxième tentative, des messages tels que « Waited 20 minutes for virtual machine to power off: Convert the image back to the virtual machine » s'affichent sur la page Activité.

Cause

Cette situation se produit, car la deuxième tentative d'exécution du processus Microsoft Sysprep est bloquée ou ne répond pas. Effectuez la procédure suivante pour résoudre le problème.

Solution

  1. Veillez à résoudre les problèmes de Microsoft Sysprep en fonction des messages d'erreur dans les journaux d'erreurs de Microsoft Sysprep et de l'article 2079196 de la base de connaissances de VMware et de l'article 2769827 de la base de connaissances de Microsoft.
  2. Sur la VM d'image, examinez le service VMware Horizon Agent et assurez-vous que son type de démarrage est défini sur Automatique.
    Si l'image se trouve dans un espace avec un manifeste d'une version antérieure à 1600, la VM dispose également du service VMware DaaS Agent. Vérifiez que le type de démarrage du service VMware DaaS Agent est défini sur Automatique.
  3. Redémarrez la VM d'image.
  4. Recommencez le processus de conversion sur la VM redémarrée.