Après avoir procédé à la mise à niveau vers VMware Identity Manager 3.3, vous devrez peut-être configurer certains des paramètres.

Configuration des instances de VMware Identity Manager Connector

Seul le connecteur externe basé sur Windows est disponible avec VMware Identity Manager 19.03.0.0 et version ultérieure. Le connecteur intégré n'est plus inclus. Le connecteur externe basé sur Linux est obsolète. La prise en charge des instances existantes de connecteur externe basé sur Linux est encore assurée pendant une période limitée. Pour bénéficier de toutes les fonctionnalités du connecteur externe, pour les versions Windows et Linux, mettez à niveau toutes les instances de connecteur vers la nouvelle version du connecteur externe basé sur Windows.

  • Installation de connecteurs externes basés sur Windows. Effectuez la procédure correspondante selon le type de connecteur à partir duquel vous effectuez la mise à niveau.

    Note:
    • Connecteur intégré. Si vous avez utilisé le connecteur intégré pour une version de VMware Identity Manager antérieure à 19.03.0.0 et que vous effectuez désormais la mise à niveau vers la version 19.03.0.0 ou version ultérieure, vous devez installer VMware Identity Manager Connector sur un système Windows.

      Pour diminuer la quantité d'informations que vous fournissez manuellement, vous pouvez effectuer les procédures nécessaires liées à la migration. Les conditions préalables suivantes s'appliquent. Lors de la mise à niveau, vous avez suivi les invites d'enregistrement de la configuration du connecteur intégré dans le fichier cluster-host-domain-conn-timestamp.enc du dossier Install-Folder\VMwareIdentityManager.

      1. Copiez le fichier cluster…enc sur le système Windows sur lequel vous prévoyez d'installer une instance correspondante de connecteur basé sur Windows.

      2. Lors de l'installation du connecteur externe basé sur Windows et par la suite, effectuez les étapes spécifiques liées à la migration. Utilisez les informations de la section Effectuer les étapes liées à la migration lors de la configuration du connecteur externe basé sur Windows pour compléter les instructions de la version correspondante du Guide d'installation et de configuration de VMware Identity Manager Connector (Windows).

    • Connecteur externe basé sur Linux. Si vous avez utilisé une ou plusieurs instances de connecteur externe basé sur Linux pour une version de VMware Identity Manager antérieure à 19.03.0.0 et que vous effectuez désormais la mise à niveau vers la version 19.03.0.0 ou version ultérieure, vous pouvez continuer d'utiliser les instances existantes de connecteur. Toutefois, le connecteur externe basé sur Linux est obsolète et ne comprend pas de nouvelles fonctionnalités. Pour bénéficier de toutes les fonctionnalités, installez le nombre correspondant d'instances de VMware Identity Manager Connector sur les systèmes Windows. Pour diminuer la quantité d'informations que vous devez fournir manuellement, vous pouvez effectuer les procédures suivantes liées à la migration.

      1. Pour enregistrer les informations de configuration du connecteur externe basé sur Linux dans un fichier cluster…enc, sur chaque instance de connecteur externe basé sur Linux, exécutez le module de migration du cluster (cluster-support.tgz). Voir Enregistrement des informations de configuration du connecteur externe basé sur Linux.

      2. Pour transférer les informations de configuration du connecteur externe basé sur Linux stockées dans les instances de fichier cluster…enc vers celles du connecteur externe basé sur Windows, copiez chaque instance de fichier cluster…enc dans un hôte Windows correspondant avant d'installer VMware Identity Manager Connector sur le système Windows. Utilisez les informations de la section Effectuer les étapes liées à la migration lors de la configuration du connecteur externe basé sur Windows pour compléter les instructions de la version correspondante du Guide d'installation et de configuration de VMware Identity Manager Connector (Windows).

      3. Lors de l'installation du connecteur externe basé sur Windows et par la suite, effectuez les étapes spécifiques liées à la migration. Voir Effectuer les étapes liées à la migration lors de la configuration du connecteur externe basé sur Windows.

    • Connecteur externe basé sur Windows. Si vous avez utilisé une ou plusieurs instances du connecteur externe basé sur Windows pour une version de VMware Identity Manager antérieure à 19.03.0.0 et que vous effectuez désormais la mise à niveau vers la version 19.03.0.0 ou version ultérieure, vous pouvez continuer d'utiliser les instances existantes de connecteur. Pour garantir, cependant, toutes les fonctionnalités des connecteurs externes existants basés sur Windows, mettez à jour les instances de connecteur vers la version 19.03.0.0 ou version ultérieure.

Activer le proxy de certificat d'Android Mobile Single Sign-On pour la surveillance des diagnostics

Si Android Mobile Single Sign-On est configuré, après avoir mis à niveau VMware Identity Manager, vous devez activer le proxy de certificat via l'interface utilisateur pour activer la surveillance des diagnostics.

Accédez à la page Paramètres du dispositif > Configuration du proxy de certificat SSO Mobile SSO Android et sélectionnez Activer le proxy de certificat. Cliquez sur Enregistrer.

Fichiers de configuration log4j

Si des fichiers de configuration log4j ont été modifiés dans une instance de VMware Identity Manager, les nouvelles versions de ces fichiers ne sont pas installées automatiquement lors de la mise à niveau. Par conséquent, après la mise à niveau, les journaux contrôlés par ces fichiers ne fonctionnent pas.

Pour résoudre ce problème :

  1. Connectez-vous à l'hôte Windows.

  2. Recherchez les fichiers log4j dotés du suffixe .rpmnew.

    find / -name "**log4j.properties.rpmnew"

  3. Pour chaque fichier trouvé, copiez le nouveau fichier dans l'ancien fichier log4j correspondant sans le suffixe .rpmnew.

Intégration de Citrix

Pour l'intégration de Citrix dans VMware Identity Manager 19.03, toutes les instances de connecteur externe doivent être de version 19.03 ou de version ultérieure.

Vous devez également effectuer la mise à niveau vers la dernière version d'Integration Broker. La mise à niveau n'est pas disponible pour Integration Broker. Désinstallez l'ancienne version, puis installez la nouvelle.