La synchronisation de ressources Horizon 7, Horizon 6 ou View avec VMware Identity Manager échoue ou est très lente.

Problème

Vous ne pouvez pas synchroniser des ressources Horizon 7, Horizon 6 ou View avec VMware Identity Manager. La synchronisation est très lente ou le processus échoue et une erreur comme la suivante s'affiche.

Échec de l'exécution de la synchronisation de View en raison d'un problème avec le Serveur de connexion View : impossible de s'authentifier sur le broker View, problème avec le répertoire

Échec de l'exécution de la synchronisation de View en raison d'un problème avec le Serveur de connexion View : impossible d'interroger un broker dans l'espace pour les informations de pool et de droit. Vérifiez la connectivité avec l'espace View

Cause

Ce problème se produit si le fichier /etc/krb5.conf ne contient pas les informations de domaine correctes.

Solution

Pour plus d'informations sur la résolution de ce problème, consultez l'article 2091744 de la base de connaissances. Les tâches de haut niveau incluent ce qui suit.

  1. Modifiez le fichier domain_krb.properties pour ajouter les domaines utilisés par View et VMware Identity Manager.

  2. Modifiez le fichier krb5.conf et mettez à jour la section realms avec les mêmes valeurs domaine-vers-l'hôte utilisées dans le fichier domain_krb.properties.

Important :

Si vous configurez plusieurs dispositifs VMware Identity Manager pour former un cluster, après la jonction d'un dispositif cloné au domaine, vous devez de nouveau mettre à jour le fichier krb5.conf avec les informations de domaine.