Le composant VMware Identity Manager Connector nécessite Java Runtime Environment (JRE).

Pourquoi et quand exécuter cette tâche

La version de JRE requise pour le connecteur est fournie avec le programme d'installation de VMware Enterprise Systems Connector. Lorsque vous mettez à niveau le composant VMware Identity Manager Connector, vous êtes également invité à mettre à niveau la version de JRE. Pour plus d'informations sur la mise à niveau de JRE pendant l'exécution du programme d'installation, reportez-vous à la section Mise à niveau de VMware Identity Manager Connector.

Si vous voulez mettre à niveau JRE sur le serveur du connecteur ultérieurement, suivez ces étapes pour vous assurer que le connecteur VMware Identity Manager continue à fonctionner correctement après la mise à niveau de JRE.

Remarque :

Si JRE est automatiquement mis à niveau, suivez les étapes 3 à 6 après la mise à niveau.

Remarque :

Cette procédure est applicable au connecteur VMware Identity Manager version 3.1 et versions ultérieures.

Procédure

  1. Arrêtez le service du connecteur.
  2. Installez la nouvelle version de JRE.
  3. Mettez à jour la variable d'environnement JAVA_HOME pour pointer vers le nouveau JRE.
  4. Modifiez le fichier %JAVA_HOME%/lib/security/java.security et ajoutez le paramètre suivant :

    crypto.policy=unlimited

  5. Ouvrez une fenêtre d'invite de commande en tant qu'administrateur et exécutez le script suivant :

    install_dir\IDMConnector\usr\local\horizon\scripts\reloadInstalledRootCerts.bat

  6. Redémarrez le service du connecteur.