Les propriétés d'ICA dans VMware Identity Manager doivent inclure la propriété de chiffrement définie au même niveau de chiffrement que celui configuré sur les serveurs XenApp dans la batterie de serveurs. Sinon, les utilisateurs ne peuvent pas accéder à leurs applications ou postes de travail publiés Citrix.

Problème

Lorsqu'un utilisateur se connecte à une ressource publiée Citrix à partir de VMware Identity Manager, le message d'erreur suivant s'affiche.

Vous ne disposez pas du niveau de chiffrement approprié pour accéder à cette session

Cause

VMware Identity Manager ne définit pas les niveaux de chiffrement. Si le niveau de chiffrement défini sur le serveur XenApp est supérieur au paramètre par défaut utilisé dans Citrix Receiver, les utilisateurs voient cette erreur.

Vous devez définir un niveau déchiffrement supérieur dans VMware Identity Manager.

Solution

  1. Connectez-vous à la console VMware Identity Manager.
  2. Cliquez sur l'onglet Catalogue > Applications virtuelles, puis cliquez sur Paramètres.
  3. Dans le volet de gauche, cliquez sur Citrix XenApp ou sur Citrix XenDesktop, en fonction de votre déploiement.
  4. Apportez les modifications suivantes dans les sections Configuration ICA et Configuration Netscaler ICA.
    1. Dans la zone de texte Propriétés du client ICA, définissez le niveau de chiffrement avec la propriété suivante :

      EncryptionLevelSession=EncRC5-128

      Cet exemple définit le niveau de chiffrement sur 128, mais vous devez le modifier au niveau configuré sur les serveurs XenApp.

    2. Dans la zone de texte Propriétés de démarrage d'ICA, définissez le niveau de chiffrement en entrant ou en modifiant la propriété suivante :

      [EncRC5-128]

      DriverNameWin16=pdc128w.dll

      DriverNameWin32=pdc128n.dll

      Cet exemple définit le niveau de chiffrement sur 128, mais vous devez le modifier au niveau configuré sur les serveurs XenApp.