Lors de la mise à niveau de NSX Intelligence à l'aide de NSX Manager Unified Appliance 2.5.x, le processus de mise à niveau peut parfois échouer à l'étape d'enregistrement du plug-in d'interface utilisateur.
Problème
nsx-intelligence> get upgrade progress-status ...output snipped... Upgrade step status: Name: update_plugin_registration State: TASK_FAILURE Errors: Registration of node failed with status code 400 Status file: wait_for_intelligence_server: resp_status: 200, body: b'{"results":[{"_links":[],"_revision":0,"_create_user":"admin","_create_time":1581934303820,"_last_modified_user":"admin","_last_modified_time":1581934303820,"_system_owned":false,"id":"default","path":"endpoints/default","end_point_address":"20.20.0.11","protocol":"https","thumbprint":"2d7efed079858e3b9d8b83647f38e48c177d56cbb1ab6669a8d63899be0a5206"}]}' Node Registration response - 400, b'{"error_code":400,"module_name":"common-service","error_message":"I/O error on GET request for \\\\\\"https://20.20.0.11/api/v1/node/version\\\\\\": No route to host (Host unreachable); nested exception is java.net.NoRouteToHostException: No route to host (Host unreachable)"}'
...output snipped... 2020-03-26 15:26:07,291 - Playbook failed at step update_plugin_registration. Run the command 'set debug-mode' followed by 'start upgrade-bundle VMware-NSX-Intelligence-appliance-1.1.0.0.0.15898874 step get_upgrade_task_history' for more info. { "info": "[MUS] UpgradeError: Playbook failed at step update_plugin_registration. Run the command 'set debug-mode' followed by 'start upgrade-bundle VMware-NSX-Intelligence-appliance-1.1.0.0.0.15898874 step get_upgrade_task_history' for more info.", "state_text": "CMD_ERROR", "state": 2, "body": null }
Cause
Ce problème peut se produire si les informations sur le nœud de NSX Manager Unified Appliance sont différentes de celles enregistrées dans le dispositif NSX Intelligence. L'adresse IP ou le certificat du nœud de NSX Manager Unified Appliance peut avoir changé depuis la dernière installation du dispositif NSX Intelligence.
Solution
Mettez à jour les informations sur l'adresse IP, le certificat et l'empreinte de certificat de NSX Manager Unified Appliance, avant de reprendre le processus de mise à niveau de NSX Intelligence. Utilisez les informations fournies dans l'article de la base de connaissances VMware https://kb.vmware.com/s/article/78505 pour résoudre ce problème.