Si votre hôte RHEL n'est pas pris en charge, mettez manuellement à niveau votre hôte RHEL à la version prise en charge.

RHEL 7.4 impose les dépendances suivantes pour que le module LCP et les composants d'hôte fonctionnent correctement.

yum-utils, wget, redhat-lsb-core, tcpdump, boost-filesystem, PyYAML, boost-iostreams, boost-chrono, python-mako, python-netaddr, python-six, gperftools-libs, libunwind, snappy, boost-date-time, c-ares, libev, python-gevent, python-greenlet

Conditions préalables

Vérifiez que l'hôte RHEL est pris en charge. Reportez-vous à la section Chemin de mise à niveau de l'hyperviseur pris en charge.

Procédure

  1. Accédez au fichier /etc/yum.conf.
  2. Définissez la mise à niveau sur la version RHEL 7.5.

    subscription-manager release --set=7.5

  3. Effacez le cache YUM.

    yum clean all

  4. Mettez à jour les modules YUM.

    yum update --releasever=7.4 update

  5. Vérifiez le fichier de configuration Grub2.

    awk -F\' '$1=="menuentry " {print $2}' /etc/grub2.cfg

    RHEL 7.4 apparaît dans le fichier grub2.cfg.

  6. Téléchargez le bundle de protocole LCP de Red Hat 7.4.

    wget <RHEL_7.4_NSXT_21_LCP_URL>

  7. Décompressez le bundle LCP téléchargé au format TAR.

    tar zxvf nsx-lcp-*rhel74_x86_64.tar.gz

  8. Installez les modules RPM.
    cd nsx-lcp-rhel74_x86_64
    rpm -Uvh --force *.rpm
  9. Supprimez les commentaires dans le fichier /etc/yum.conf pour revenir à l'état d'origine.

    exclude=[existing list] kernel* redhat-release*

  10. Pour mettre à niveau NSX-T Data Center 2.1 vers NSX-T Data Center 2.3, désinstallez netcpa avec l'option--noscripts.
    rpm -evv --noscripts --nodeps nsx-netcpa 2>&1
    if [ -f /opt/vmware/bin/netcpa.sh ]; then
       rm /opt/vmware/bin/netcpa.sh
    fi

Que faire ensuite

Vous pouvez également procéder à une mise à niveau vers RHEL 7.5 pris en charge