NSX Container Plug-in (NCP) a les conditions requises de compatibilité suivantes pour un environnement Kubernetes et un environnement Pivotal Cloud Foundry (PCF).

Tableau 1. Conditions requises de compatibilité pour un environnement Kubernetes
Produit logiciel Version
NSX-T Data Center 2.3, 2.4
Hyperviseur pour machines virtuelles d'hôte de conteneur
Système d'exploitation d'hôte de conteneur
  • RHEL 7.5, 7.6
  • Ubuntu 16.04
  • CentOS 7.4, 7.5
Orchestrateur de conteneur Kubernetes 1.12, 1.13
Open vSwitch d'hôte de conteneur 2.9.1 (fourni avec NSX-T Data Center 2.3.x), 2.10.2 (fourni avec NSX-T Data Center 2.4.0)
Tableau 2. Conditions requises de compatibilité pour un environnement Cloud Foundry
Produit logiciel Version
Hyperviseur pour machines virtuelles d'hôte de conteneur
Orchestrateur de conteneur
  • Pivotal Application Service 2.3.x et Pivotal Operations Manager 2.3.x
  • Pivotal Application Service 2.4.x (à l'exception de 2.4.0) et Pivotal Operations Manager 2.4.x (à l'exception de 2.4.0)