Vous ne pouvez pas collecter les bundles de support NSX Application Platform à l'aide de l'interface utilisateur de NSX Manager.

Problème

Vous avez tenté de déployer ou de supprimer NSX Application Platform, mais cela a échoué avant de terminer l'opération de déploiement ou de suppression. Étant donné que NSX Application Platform n'est plus accessible, il n'est pas possible d'accéder aux bundles de support à l'aide de l'interface utilisateur de NSX Manager pour savoir ce qui a provoqué l'échec de l'opération.

Cause

Plusieurs raisons peuvent expliquer l'échec de l'opération de déploiement ou de suppression.

Solution

Pour connaître la raison de l'échec de l'opération de déploiement ou de suppression, utilisez les informations suivantes pour collecter les bundles de support à l'aide de la CLI NSX Manager.
  1. Connectez-vous à la CLI du dispositif NSX Manager en tant qu'utilisateur Admin.
  2. Avant de générer le bundle de support, entrez la commande suivante à l'invite de la CLI.
    set napp kubeconfig
  3. Entrez le contenu du fichier kubeconfig et appuyez sur Ctrl+D.

    Cette action remplace tout fichier kubeconfig existant utilisé par NSX Application Platform.

  4. Obtenez le fichier de bundle de support à l'aide de la commande suivante, où support-bundle-filename est le nom de fichier que vous souhaitez que le système utilise pour le fichier de bundle de support généré.
    get support-bundle file support-bundle-filename.tgz
    

    Si vous avez entré un contenu de fichier kubeconfig valide, vous pouvez trouver les fichiers journaux de prise en charge de NSX Application Platform dans le dossier /napp après avoir décompressé le fichier support-bundle-filename.tgz.

    Si le contenu du fichier kubeconfig que vous avez entré n'est pas valide, le dossier /napp est vide.

  5. Pour transférer le fichier du bundle de support en toute sécurité depuis l'hôte NSX Manager vers un emplacement d'hôte distant, utilisez la commande suivante.
    copy file support-bundle-filename.tgz url remote-host-url

    remote-host-url est au format scp://<username>@<ip-address>:<dir>, où <username> est un compte d'utilisateur valide ayant accès à l'hôte distant, <ip-address> est l'adresse IP de l'hôte distant et <dir> est le dossier de fichiers vers lequel le fichier du bundle de support doit être transféré.