La mise à niveau de NSX Application Platform a échoué en raison d'une erreur.

Problème

Une tentative de mise à niveau de NSX Application Platform a échoué avec l'erreur Déploiement du coordinateur de mise à niveau : échec de l'appel du plug-in après le déploiement du coordinateur de mise à niveau.

Cause

Si la connectivité entre le nœud du plan de contrôle Kubernetes et un espace existant est perdue, le gestionnaire de certificats Kubernetes ne parvient pas à envoyer le certificat à l'espace existant et les appels d'API de sortie envoyés à NSX Manager échouent. Ce problème peut également se produire en cas de problème de connectivité entre le nœud Coordinateur de mise à jour et le nœud du plan de contrôle Kubernetes.

Solution

Pour résoudre ce problème, procédez comme suit.

  1. Connectez-vous au dispositif NSX Manager avec le compte root.

  2. À l'invite du système, exécutez la commande suivante pour redémarrer les espaces.

    napp-k rollout restart deployment cluster-api trust-manager 
  3. Attendez que les espaces cluster-api et trust-manager redémarrent.

  4. Une fois les espaces à nouveau en ligne, redémarrez le déploiement du coordinateur de mise à niveau à l'aide de la commande suivante.

    napp-k rollout restart deployment upgrade-coordinator
  5. Attendez que le coordinateur de mise à niveau redémarre.

  6. Retentez la mise à niveau de NSX Application Platform à l'aide de l'onglet Système > Mettre à niveau dans l'interface utilisateur de NSX Manager. Pour plus d'informations, reportez-vous à la section Mettre à niveau NSX Application Platform.