L'assistant d'activation NSX Network Detection and Response signale une erreur après une tentative de déploiement du composant NSX Cloud Connector.

Problème

Dans le cadre de l'activation de la fonctionnalité NSX Network Detection and Response, l'assistant d'activation tente de déployer le composant NSX Cloud Connector. NSX Cloud Connector enregistre l'installation NSX dans le service cloud NSX Advanced Threat Prevention et crée un canal sécurisé entre les ressources locales et les ressources de cloud. Si un problème se produit pendant ces étapes, l'assistant d'activation signale une erreur de déploiement NSX Cloud Connector, ce qui bloque l'activation de NSX Network Detection and Response pour continuer et elle finit par expirer.

Cause

NSX Cloud Connector établit la connectivité à la région de service de cloud NSX Advanced Threat Prevention que vous avez sélectionnée et il déclenche l'enregistrement à l'aide des licences NSX. Si la connexion n'est pas disponible, l'enregistrement échoue ou expire.

Solution

  1. NSX Cloud Connector utilise le même canal de communication que celui précédemment validé lors de la vérification préalable de l'activation de NSX Network Detection and Response. Si la configuration NSX a été modifiée entre l'exécution de la vérification préalable NSX Network Detection and Response et l'activation réelle de NSX Network Detection and Response, exécutez à nouveau la vérification préalable d'activation. Si vous rencontrez une erreur, suivez les informations de dépannage pour l'échec de la vérification préalable à l'activation.
  2. Assurez-vous que NSX Application Platform est déployé correctement et qu'il est signalé comme STABLE sur la page de l'interface utilisateur Systèmes > NSX Application Platform.
  3. Examinez les journaux pour le service d’enregistrement NSX Cloud Connector.
    1. Collectez un bundle de support NSX Application Platform et examinez les journaux pour tout espace Kubernetes portant le nom commençant par cloud-connector-register.
    2. Vous pouvez également interroger les journaux de manière interactive sur le dispositif NSX Manager en procédant comme suit.
      1. Connectez-vous au dispositif NSX Manager en tant que root.
      2. Utilisez la commande suivante pour marquer la configuration Kubernetes pour toutes les invocations helm et kubectl suivantes.
        export KUBECONFIG=/config/vmware/napps/.kube/config
      3. À l'aide de la commande suivante, assurez-vous que le graphique Helm NSX Cloud Connector est correctement déployé.
        helm --namespace nsxi-platform list --all --filter 'cloud-connector'
        Vérifiez que la propriété STATUS affiche deployed.
      4. Vérifiez que l'espace d'enregistrement est déployé et terminé.
        kubectl --namespace nsxi-platform get pods --selector='job-name=cloud-connector-register'
        L'espace doit afficher STATUS comme Terminé.
      5. Inspectez les événements de l’espace d’enregistrement à l’aide de la commande suivante.
        kubectl --namespace nsxi-platform describe pod --selector='job-name=cloud-connector-register'
        
        La section Événements fournit l'état de la tâche d'enregistrement et les actions associées à la tâche.
      6. Utilisez la commande suivante pour inspecter les journaux de l’espace d’enregistrement.
        kubectl --namespace nsxi-platform logs --selector='job-name=cloud-connector-register' --container=main
  4. Après avoir résolu l'erreur, cliquez sur Actions dans la carte de fonctionnalité NSX Network Detection and Response. Sélectionnez Supprimer pour lancer la suppression de la fonctionnalité NSX Network Detection and Response partiellement activée. Une fois le processus de suppression terminé, réessayez d'activer la fonctionnalité.