Échec de l'opération de déploiement de NSX Application Platform en raison d’un délai d'expiration.

Problème

Une tentative de déploiement de NSX Application Platform a échoué et l'opération a expiré.

Cause

Le processus de déploiement de NSX Application Platform inclut l'installation de plusieurs services utilisés pour la messagerie, le stockage de données, l'analyse, etc. Si ces services ne démarrent pas dans les 20 minutes qui suivent le lancement du déploiement, le processus de déploiement est arrêté avec une erreur de délai d'expiration. Les causes possibles de l'erreur de délai d'expiration sont des problèmes d'infrastructure, tels qu'une contention de CPU, une contention de stockage ou des problèmes de connectivité réseau.

Solution

  1. Connectez-vous au dispositif NSX Manager avec des privilèges d'administrateur.
  2. Utilisez la commande suivante pour vérifier que les espaces nsxi-platform sont déployés correctement.
    napp-k get pods --selector='app.kubernetes.io/instance=nsxi-platform'

    Si l'état de l'espace est En cours d’exécution ou Terminé, cela signifie que l'espace a démarré correctement.

    Si l'un des états d'espace suivants continue d'être renvoyé, il peut indiquer qu'un espace n'a pas démarré correctement.
    • Init/Podinitializing/CrashLoopBackOff
    • En attente
    • ContainerCreating
    • ImagePullBackOff
    • ErrImagePull
    • ImageInspectError
    • CreateContainerConfigError
  3. Si l'un des espaces ne démarre pas dans les 20 minutes qui suivent le lancement du déploiement et que le déploiement s'arrête avec une erreur de délai d'expiration, recherchez s'il existe des problèmes avec l'infrastructure, tels qu'une contention de CPU, une contention de stockage ou un problème de connectivité réseau. Résolvez les problèmes et réessayez le déploiement de NSX Application Platform à partir de l'interface utilisateur NSX Manager.
  4. Si le déploiement continue d'expirer, utilisez la commande suivante pour inspecter les fichiers journaux de chaque espace qui ne parvient pas à démarrer.
    Obtenez le <POD_NAME> à partir de la sortie de la commande à l'étape 2.
    napp-k logs <POD_NAME>
  5. Résolvez les erreurs signalées dans les fichiers journaux et réessayez le déploiement de NSX Application Platform à partir de l'interface utilisateur NSX Manager.
  6. Si le déploiement continue d'échouer, contactez votre support VMware pour obtenir de l'aide.