Si votre dispositif virtuel de service existant, version 20.01 ou 19.03 est connecté à Internet, vous pouvez effectuer la mise à niveau du dispositif en ligne.

Conditions préalables

Procédure

  1. Connectez-vous au dispositif virtuel de service existant en tant qu'utilisateur racine.
  2. Exécutez la commande updatemgr.hzn suivante.
    /usr/local/horizon/update/updatemgr.hzn updateinstaller
  3. Exécutez la commande suivante pour vérifier qu'une mise à niveau en ligne existe.
    /usr/local/horizon/update/updatemgr.hzn check
  4. Exécutez la commande suivante pour mettre à jour le dispositif.
    /usr/local/horizon/update/updatemgr.hzn update --file /db/dualbootupdate.tar.gz
    Si vous n'incluez pas l'option --file, vous êtes invité à fournir le fichier dualbootupdate, dont la valeur par défaut est /dualbootupdate.tar.gz.
    Les messages générés pendant la mise à niveau sont enregistrés dans le fichier update.log à l'emplacement /opt/vmware/var/log/update.log.
  5. Entrez y pour poursuivre la mise à niveau du service Workspace ONE Access ou n pour quitter la mise à niveau.
    L'invite vous donne la possibilité de prendre en compte les informations suivantes sur les applications virtuelles.
    Important : Les intégrations de Citrix, d'Horizon Cloud et de ThinApp ne sont pas disponibles avec Workspace ONE Access 20.10 ou 20.01 Connector.
    • Pour utiliser des applications packagées ThinApp, utilisez VMware Identity Manager Connector (Linux) version 2018.8.1.0.
    • Pour utiliser d'autres applications virtuelles, telles que des applications et des postes de travail Horizon, ou des ressources publiées Citrix, utilisez la version 19.03.0.1 de VMware Identity Manager Connector (Windows).

    Vous pouvez procéder à la mise à niveau, que vous prévoyiez ou non d'utiliser des applications virtuelles. Cependant, les versions 20.10 et 20.01 du service Workspace ONE Access prennent en charge les applications virtuelles, mais pas les versions 20.10 et 20.01 de Workspace ONE Access Connector. Par conséquent, si vous prévoyez d'utiliser des applications virtuelles avec la version 20.10 ou 20.01 du service Workspace ONE Access, vous ne pouvez pas effectuer la mise à niveau vers la version 20.01 ou 20.10 de Workspace ONE Access Connector.

  6. Exécutez de nouveau la commande updatemgr.hzn check pour vérifier qu'une mise à jour plus récente n'existe pas.
    /usr/local/horizon/update/updatemgr.hzn check
  7. Redémarrez le dispositif virtuel.
    reboot
  8. Vérifiez la version du dispositif mis à niveau.
    vamicli version --appliance
    La nouvelle version est affichée.

Résultats

La mise à niveau est terminée.

Voir Configuration après la mise à niveau.