Pour intégrer un déploiement Citrix au service Workspace ONE Access, vous avez besoin des composants suivants.

  • Locataire de service de cloud Workspace ONE Access ou instance sur site.
  • Une ou plusieurs instances du service d'applications virtuelles déployées sur site. Le service d'applications virtuelles est un composant de Workspace ONE Access Connector 21.08 et versions ultérieures. Vous pouvez télécharger le connecteur sur la page du produit Workspace ONE Access sur https://my.vmware.com.

    Lorsque vous installez le service d'applications virtuelles, veillez à respecter la configuration requise et les conditions préalables à l'intégration Citrix décrites dans le Guide d'installation de VMware Workspace ONE Access Connector. Celles-ci incluent :

    • Le serveur du service d'applications virtuelles doit être joint au domaine d'annuaire.
    • Vous devez spécifier un compte d'utilisateur de domaine à utiliser pour exécuter le service d'applications virtuelles. Cet utilisateur de domaine doit également être un administrateur de serveur Citrix en lecture seule capable de charger Citrix PSSnapin.
    • Vous devez installer Citrix Studio sur le serveur du service d'applications virtuelles. Citrix Studio inclut Citrix PowerShell SDK, qui est requis pour l'intégration entre Citrix et Workspace ONE Access. La version de Citrix Studio est compatible avec votre version de déploiement Citrix.
  • Un déploiement Citrix sur site.

Lors du déploiement des composants sur site, veillez à remplir les conditions requises suivantes :

  • Toutes les instances du service d'applications virtuelles doivent pouvoir communiquer avec la batterie de serveurs Citrix.
  • Toutes les instances du service d'applications virtuelles doivent pouvoir communiquer avec Citrix StoreFront.

Toutes les communications entre le service Workspace ONE Access et les composants sur site se font via le connecteur. Le connecteur et le service communiquent sur un canal de communication qui est automatiquement configuré lors de l'installation.

Note : Il est recommandé d'utiliser la dernière version disponible de Workspace ONE Access et de ses composants.