Pour effectuer une migration vers Workspace ONE Access Connector  22.05, vous devez remplir les conditions requises suivantes.

  • Vous avez besoin d'un ou de plusieurs serveurs Windows pour installer Connector 22.05. Vous pouvez installer conjointement les services de synchronisation d'annuaire, d'authentification utilisateur, d'authentification Kerberos et d'applications virtuelles sur un seul serveur ou séparément sur des serveurs différents. Pour obtenir les considérations et les conditions requises, reportez-vous à la section Installation de VMware Workspace ONE Access Connector 22.05.

    Vous pouvez installer Connector 22.05 sur un nouveau serveur ou sur le serveur Connector 19.03.x hérité. Toutefois, vous devez installer le service d'authentification Kerberos 22.05 sur un serveur distinct si l'authentification Kerberos est configurée sur le connecteur hérité. N'installez pas le nouveau service Authentification Kerberos sur le serveur Connector 19.03.x. Workspace ONE Access ne prend pas en charge plusieurs instances de Kerberos sur le même serveur.

    Si vous prévoyez d'installer Connector 22.05 sur un nouveau serveur Windows, reportez-vous à la section Configuration système requise de Workspace ONE Access Connector 22.05 dans la section Installation de VMware Workspace ONE Access Connector 22.05. Si vous prévoyez d'installer Connector 22.05 sur le serveur Connector 19.03.x, reportez-vous à la section Migration vers la dernière version de Connector sur un serveur Windows exécutant Workspace ONE Access 19.03.x.

  • Si votre installation existante inclut des applications virtuelles Citrix, lorsque vous installez le service d'applications virtuelles, veillez à respecter la configuration requise et les conditions préalables à l'intégration Citrix décrites dans le Guide d'installation de VMware Workspace ONE Access Connector 22.05. Celles-ci incluent :
    • Le serveur du connecteur doit être joint au domaine de l'annuaire.
    • Vous devez spécifier un compte d'utilisateur de domaine à utiliser pour exécuter le service d'applications virtuelles. Cet utilisateur de domaine doit également être un administrateur de serveur Citrix en lecture seule capable de charger Citrix PSSnapin.
    • Vous devez installer Citrix Studio sur le serveur du connecteur. Citrix Studio inclut Citrix PowerShell SDK qui est requis pour l'intégration entre Citrix et Workspace ONE Access. La version de Citrix Studio est compatible avec votre version de déploiement Citrix.
  • Pour les collections d'applications virtuelles Horizon et Horizon Cloud, assurez-vous que les instances d'Horizon Connection Server disposent de certificats valides signés par une autorité de certification (CA) approuvée. Si les instances d'Horizon Connection Server disposent de certificats auto-signés, vous devez télécharger la chaîne de certificats vers les instances de Workspace ONE Access Connector sur lesquelles le service d'applications virtuelles est installé pour établir une relation de confiance entre les connecteurs et les instances d'Horizon Connection Server. Il s'agit d'une nouvelle exigence à partir de Workspace ONE Access Connector 21.08. Téléchargez les certificats à l'aide du programme d'installation du connecteur. Pour plus d'informations, reportez-vous à la section Installation de VMware Workspace ONE Access Connector 22.05. Assurez-vous de redémarrer les services du connecteur après le téléchargement des certificats.
  • Pendant le processus de migration, vous basculez des anciens connecteurs vers les nouveaux connecteurs afin de tester la migration. Les serveurs de 19.03.x Connector hérité doivent être en cours d'exécution pendant le processus de migration. Ne désinstallez pas les instances de 19.03.x Connector tant que la migration n'est pas terminée.
  • Toutes les instances de Connector existantes de votre locataire doivent être de version 19.03.x. Si vous disposez d'anciennes versions, mettez-les à niveau vers la version 19.03.x.
  • Lors de la migration, vous devez migrer tous les annuaires et toutes les collections d'applications virtuelles prises en charge dans le locataire vers Connector 22.05. Vous ne pouvez pas choisir de migrer un sous-ensemble d'annuaires ou d'applications virtuelles, ni de migrer uniquement des annuaires ou des applications virtuelles.
  • Si vous installez le service d'authentification utilisateur, assurez-vous que toutes les instances de Connector sur lesquelles le service d'authentification utilisateur est installé sont de version 22.05. Workspace ONE Access ne prend pas en charge la combinaison des versions 22.05, 21.08.x et 20.x du service d'authentification utilisateur.
  • Après la migration, vous ne pouvez utiliser que les nouvelles instances de Connector 22.05. Vous ne pouvez pas combiner des instances de Connector 19.03.x héritées et des instances de Connector 22.05 dans votre environnement.
  • Workspace ONE Access Connector 22.05 prend en charge les types de proxys suivants :
    • Proxys HTTP non authentifiés
    • Proxys HTTPS (SSL) non authentifiés
    • Proxys HTTPS (SSL) authentifiés

Migration vers la dernière version de Connector sur un serveur Windows exécutant Workspace ONE Access Connector 19.03.x

Lorsque vous ne pouvez pas obtenir un nouveau serveur Windows pour effectuer une migration vers Workspace ONE Access Connector 22.05, vous pouvez installer Connector 22.05 sur un serveur Windows qui exécute Workspace ONE AccessConnector 19.03.x. Vous pouvez ensuite migrer votre connecteur hérité.

Attention : Si l'authentification Kerberos est configurée sur le connecteur hérité, vous devez installer le nouveau service d'authentification Kerberos 22.05 sur un serveur Windows distinct. N'installez pas le service Authentification Kerberos sur le serveur Connector 19.03. x. Workspace ONE Access ne prend pas en charge plusieurs instances de Kerberos sur le même serveur.

Si vous utilisez un serveur Windows existant sur lequel Connector 19.03.x est installé, veillez à suivre les recommandations suivantes :

  • Avant d'installer Connector 22.05, vous devez augmenter le CPU et la mémoire sur le serveur. Deux versions du connecteur seront exécutées jusqu'à la fin de la migration.

    Vous devez augmenter le CPU et la mémoire pour répondre aux besoins des instances de Connector 19.03.x et 22.05. Reportez-vous aux Recommandations de dimensionnement de la version 22.05 dans la section Installation de VMware Workspace ONE Access Connector 22.05.

  • IMPORTANT : prenez un snapshot de la machine avant d'exécuter le programme d'installation de Connector 22.05. Lorsque vous installez Connector 22.05, à la fin du processus d'installation vous pouvez recevoir une invite pour redémarrer l'hôte du connecteur. Ne redémarrez pas l'hôte. Si vous le faites, le processus de migration échouera et votre instance de Connector 19.03.x ne sera plus inutilisable. Il est essentiel de ne pas redémarrer la machine tant que le processus complet de migration n'est pas terminé. Une fois la migration terminée, vous pouvez redémarrer la machine en toute sécurité.
  • N'arrêtez pas ou ne désinstallez pas les instances de Connector 19.03.x tant que la migration n'est pas terminée.

Une fois la migration terminée, vous pouvez arrêter l'instance de 19.03.x Connector et la désinstaller.