La synchronisation de répertoire se termine correctement, mais aucun utilisateur n'est affiché dans les groupes synchronisés.

Problème

Une fois qu'un répertoire est synchronisé, manuellement ou automatiquement en fonction du planning de synchronisation, le processus de synchronisation se termine correctement, mais aucun utilisateur n'est affiché dans les groupes synchronisés.

Note : Vérifiez que le groupe est autorisé à accéder à une application ou que le nom du groupe a été ajouté à une règle de stratégie d'accès. Lorsque vous ajoutez des groupes et que vous les synchronisez, seuls les noms de groupe sont synchronisés avec l'annuaire. Les utilisateurs qui sont membres du groupe ne sont synchronisés avec l'annuaire qu'une fois que le groupe dispose de droits d'accès à une application ou que le nom du groupe est ajouté à une règle de stratégie d'accès.

Cause

Ce problème peut se produire lorsque vous disposez de deux nœuds ou plus dans un cluster et qu'il existe une différence de temps de plus de 5 secondes entre les nœuds.

Solution

  1. Vérifiez qu'il n'existe pas de différence de temps entre les nœuds. Utilisez le même serveur NTP sur tous les nœuds dans le cluster pour synchroniser le temps.
  2. Redémarrez le service sur tous les nœuds.
    service horizon-workspace restart
  3. (Facultatif) Dans la Console Workspace ONE Access, supprimez le groupe, rajoutez-le dans les paramètres de synchronisation, puis synchronisez de nouveau l'annuaire.