La mise à niveau échoue avec une erreur « Mise à jour de la configuration de l'authentification du certificat requise ».

Problème

Lorsque vous essayez d'effectuer la mise à niveau vers VMware Identity Manager 3.3.2, le message d'erreur suivant s'affiche et la mise à niveau est abandonnée.

Mise à jour de la configuration de l'authentification du certificat requise pour le locataire <tenantName> avant la mise à niveau. Échec de la vérification préalable à la mise à jour, abandon de la mise à niveau.

Cause

Ce problème se produit si les certificats de CertificateAuthAdapter ont été récemment ajoutés ou mis à jour avant la version 3.0.

Solution

  1. Connectez-vous à la console VMware Identity Manager.
  2. Accédez à Gestion des identités et des accès > Configuration.
  3. Sur la page Connecteurs, cliquez sur le lien de la colonne Employé.
  4. Cliquez sur l'onglet Adaptateurs d'authentification, puis sur CertificateAuthAdapter.
  5. Dans la section Certificats d'autorité de certification chargés, cliquez sur la croix rouge pour supprimer le certificat.
  6. Cliquez sur Enregistrer.
  7. Dans la section Certificats d'autorité de certification racine et intermédiaire, cliquez sur Sélectionner un fichier pour rajouter le certificat.
  8. Cliquez sur Enregistrer.
  9. Revenez à la console du dispositif virtuel et réexécutez les commandes de mise à niveau.