Les propriétés ICA XenApp dans VMware Identity Manager doivent inclure l'ensemble de propriétés de chiffrement défini au même niveau de chiffrement que celui configuré sur les serveurs XenApp dans la batterie de serveurs, sinon les utilisateurs ne pourront pas accéder à leurs applications ou postes de travail publiés Citrix.
Problème
Lorsqu'un utilisateur se connecte à une ressource publiée Citrix à partir de
VMware Identity Manager, le message d'erreur suivant s'affiche.
Vous ne disposez pas du niveau de chiffrement approprié pour accéder à cette session
Cause
VMware Identity Manager ne définit pas les niveaux de chiffrement. Si le niveau de chiffrement défini sur le serveur XenApp est supérieur au paramètre par défaut utilisé dans Citrix Receiver, les utilisateurs obtiennent cette erreur.
Vous devez définir un niveau déchiffrement supérieur dans Workspace.
Solution
- Connectez-vous à la console VMware Identity Manager.
- Cliquez sur l'onglet Paramètres de l'application virtuelle. , puis cliquez sur
- Sélectionnez Applications publiées Citrix.
- Apportez les modifications suivantes dans les onglets Configuration ICA et Configuration Netscaler ICA.
- Modifiez la zone de texte Propriétés ICA Client. Pour définir le niveau de chiffrement sur 128, entrez
EncryptionLevelSession=EncRC5-128.
- Modifiez la zone de texte Propriétés de lancement ICA. Pour définir le niveau de chiffrement sur 128, entrez
[EncRC5-128]
DriverNameWin16=pdc128w.dll
DriverNameWin32=pdc128n.dll.
- Modifiez la zone de texte Propriétés ICA Client. Pour définir le niveau de chiffrement sur 128, entrez