Une non-correspondance entre les configurations de la batterie de serveurs Citrix et de Workspace ONE Access peut entraîner l'échec du lancement de ressources publiées Citrix.

Problème

Le lancement d'une ressource publiée Citrix échoue lorsque le navigateur affiche une erreur de serveur interne 500.

Cause

Une erreur 500 se produit lorsque les informations sur la batterie de serveurs Citrix dans la console Workspace ONE Access ne correspondent pas à la configuration du serveur Citrix.

Solution

  1. Notez les paramètres du type de transport, du numéro de port et du numéro de port relais SSL de chaque batterie de serveurs intégrée dans votre déploiement Workspace ONE Access.
  2. Connectez-vous à la console Workspace ONE Access.
  3. Sélectionnez l'onglet Catalogue > Collections d'applications virtuelles.
  4. Cliquez sur la collecte d'applications virtuelles Citrix, puis sur Modifier.
  5. Dans l'assistant Modifier la collecte Citrix XenApp, cliquez sur Batterie de serveurs dans le volet de gauche, puis sur la batterie de serveurs à modifier.
  6. Sous Préférence de lancement, Web Interface SDK, modifiez les paramètres Type de transport, Port et Port de relais SSL afin qu'ils correspondent à ceux de la configuration du serveur Citrix.
  7. Cliquez sur Enregistrer.
  8. Répétez ces étapes pour modifier les paramètres de chaque batterie de serveurs.