Les versions antérieures des services Broker Agent et Desktop Agent ne peuvent pas communiquer avec l'Adaptateur Horizon.

Problème

À compter de vRealize Operations for Horizon 6.1 ou version antérieure, les services Broker Agent et Desktop Agent ne peuvent pas communiquer avec l'Adaptateur Horizon par défaut.

Cause

vRealize Operations for Horizon 6.2.1 et version ultérieure applique TLS 1.2, contrairement aux versions antérieures qui utilisent TLS 1.0. Si vous ne pouvez pas mettre à niveau les services Agent vers une version plus récente, vous pouvez désactiver TLS sur l'adaptateur.

Solution

  1. Ouvrez le fichier /usr/lib/vmware-vcops/user/plugins/inbound/V4V_adapter3/work/msgserver.properties sur le nœud de collecteur vRealize Operations Manager.
  2. Ajoutez la commande suivante :
    enforcesslprotocols=false
  3. Redémarrez l'Adaptateur Horizon.
  4. Sur l'hôte d'Horizon Connection Server sur lequel le service Broker Agent est installé, associez de nouveau le service Broker Agent à l'adaptateur.