Il existe plusieurs scénarios dans lesquels le client vSphere Bitfusion ne parvient pas à se connecter aux serveurs vSphere Bitfusion de votre cluster.

Problème

Lorsque vous tentez de connecter un client vSphere Bitfusion aux serveurs de votre cluster, la connexion échoue. En général, vous voyez un message d'erreur semblable à l'exemple suivant.

Error querying server 10.115.27.120:56001:
Get https://10.115.27.120:56001/query: x509: certificate signed by unknown authority
Unable to contact any of the existing servers: 10.115.27.120:56001

Cause

  • Lorsque vous déplacez ou clonez un client vSphere Bitfusion vers une nouvelle instance de vCenter Server.
  • Lorsque vous installez de nouveaux serveurs vSphere Bitfusion, ce qui entraîne la création d'un cluster, et que vous utilisez vos anciens clients vSphere Bitfusion.
  • Lorsque votre cluster comprend un serveur vSphere Bitfusion non valide.

Solution

  • Si votre inventaire contient un serveur vSphere Bitfusion non valide, supprimez-le du cluster à l'aide du plug-in vSphere Bitfusion.

    Pour plus d'informations, consultez Suppression d'un serveur vSphere Bitfusion.

    Si le serveur ne peut pas être supprimé de l'inventaire à l'aide du plug-in vSphere Bitfusion, exécutez la commande bitfusion removenode sur le terminal d'un serveur vSphere Bitfusion en cours d'exécution.

  • Vérifiez que toutes les étapes du processus d'activation du client vSphere Bitfusion ont été effectuées.

    Par exemple, vérifiez que la machine virtuelle du client vSphere Bitfusion est hors tension pendant le processus d'activation.

    Pour plus d'informations, reportez-vous à la section Activation du client vSphere Bitfusion du Installation de VMware vSphere Bitfusion.

  • Dans le terminal de la machine virtuelle du client vSphere Bitfusion, exécutez les commandes suivantes.
    1. rm ~/.bitfusion/client.yaml
    2. rm ~/.bitfusion/servers.conf
    Après la suppression de client.yaml et de servers.conf, réactivez le client vSphere Bitfusion.

    Pour plus d'informations, reportez-vous à la section Activation du client vSphere Bitfusion du Installation de VMware vSphere Bitfusion.

  • Si aucune des étapes précédentes ne résout le problème, créez des journaux à partir d'un serveur vSphere Bitfusion et envoyez le bundle de support au support VMware.

    Pour plus d'informations, consultez Génération d'un bundle de support à partir d'un serveur vSphere Bitfusion.