L'installation de vCenter Server avec une base de données SQL Microsoft échoue lorsque la base de données est définie sur le mode de compatibilité avec une version non prise en charge.

Problème

Le message d'erreur suivant apparaît : L'utilisateur de base de données saisi ne dispose pas des autorisations nécessaires à l'installation et à la configuration de vCenter Server avec la base de données sélectionnée. Veuillez corriger la ou les erreur(s) suivante(s) : %s

La version de la base de données doit être prise en charge pour vCenter Server. Pour SQL, même si la base de données est une version prise en charge, si elle est définie pour être exécutée en mode compatibilité avec une version non prise en charge, cette erreur se produit. Par exemple, si SQL 2008 est défini pour être exécuté en mode compatibilité SQL 2000, cette erreur se produit.

Procédure

Assurez-vous que la base de données vCenter Server est une version prise en charge et qu'elle n'est pas définie sur le mode compatibilité avec une version non prise en charge. Reportez-vous au document Matrices d’interopérabilité des produits VMware à l'adresse suivante : http://partnerweb.vmware.com/comp_guide2/sim/interop_matrix.php?.