Avec vSphere CLI, vous pouvez mettre à niveau, mettre à jour ou appliquer des correctifs aux hôtes ESXi 5.x.

Vous ne pouvez pas utiliser les commandes esxcli pour mettre à niveau des hôtes ESX ou ESXi version 4.x vers ESXi 5.x. Pour mettre à niveau des hôtes ESX ou ESXi de version 4.x vers ESXi 5.x, utilisez vSphere Update Manager ou effectuez une mise à niveau interactive ou scriptée.

Pour utiliser les commandes esxcli de l'interface de ligne de commande, vous devez installer vSphere CLI (vCLI). Pour plus d'informations sur l'installation et l'utilisation de vSphere CLI, consultez les documents suivants :

  • Initiation aux interfaces de ligne de commande vSphere

  • Concepts et exemples de l'interface de ligne de commande vSphere

  • Référence de l'interface de ligne de commande de vSphere est un document de référence sur la commande vicfg- et commandes apparentées de vCLI.

Remarque :

Si vous appuyez sur Ctrl+C pendant l'exécution d'une commande esxcli, l'interface de ligne de commande ouvre une nouvelle invite sans afficher de message. La commande continue cependant de s'exécuter jusqu'à sa fin.

Pour les hôtes ESXi déployés avec vSphere Auto Deploy, les outils VIB doivent faire partie de l'image de démarrage de base utilisée pour l'installation initiale de la fonction Auto Deploy. Il est impossible d'ajouter les outils VIB séparément par la suite.