Lors de la création d'une machine virtuelle ou de la mise à niveau d'une machine virtuelle existante, vous utilisez le paramètre de compatibilité de la machine virtuelle pour sélectionner les versions d'hôte ESXi sur lesquelles exécuter la machine virtuelle.

Le paramètre de compatibilité détermine le matériel virtuel disponible pour la machine virtuelle, qui correspond au matériel physique disponible sur l'hôte. Le matériel virtuel inclut le BIOS et l'EFI, le nombre d'emplacements PCI virtuels, le nombre maximal de processeurs, la configuration de mémoire maximale et d'autres caractéristiques. Les nouvelles capacités matérielles virtuelles sont généralement publiées une fois par an avec les versions majeures ou mineures de vSphere.

Chaque niveau de compatibilité de machine virtuelle prend en charge au moins cinq versions majeures ou mineures de vSphere. Par exemple, une machine virtuelle compatible avec ESXi 3.5 et versions ultérieures peut s'exécuter sur ESXi 3.5, ESXi 4.0, ESXi 4.1, ESXi 5.0, ESXi 5.1 et ESXi 5.5.

Tableau 1. Options de compatibilité de la machine virtuelle

Compatibilité

Description

ESXi 5.5 et versions ultérieures

Cette machine virtuelle (version matérielle 10) est compatible avec ESXi 5.5 et versions ultérieures.

ESXi 5.1 et versions ultérieures

Cette machine virtuelle (version matérielle 9) est compatible avec ESXi 5.1 et ESXi 5.5.

ESXi 5.0 et versions ultérieures

Cette machine virtuelle (version matérielle 8) est compatible avec ESXi 5.0, ESXi 5.1 et ESXi 5.5.

ESX/ESXi 4.0 et versions ultérieures

Cette machine virtuelle (version matérielle 7) est compatible avec ESX/ ESXi 4.0, ESX/ ESXi 4.1, ESXi 5.0, ESXi 5.1 et ESXi 5.5.

ESX/ESXi 3.5 et versions ultérieures

Cette machine virtuelle (version matérielle 4) est compatible avec ESX/ESXi 3.5, ESX/ ESXi 4.0, ESX/ ESXi 4.1, ESXi 5.1 et ESXi 5.5. Elle est également compatible avec VMware Server 1.0 et versions ultérieures. ESXi 5.0 ne permet pas la création de machines virtuelles compatibles avec ESX/ESXi 3.5 et versions ultérieures, mais vous pouvez exécuter ces machines virtuelles si elles ont été créées sur un hôte avec une compatibilité différente.

ESX Server 2.x et versions ultérieures

Cette machine virtuelle (version matérielle 3) est compatible avec ESX Server 2.x, ESX/ESXi 3.5 et 4.x et ESXi 5.0. Vous ne pouvez pas créer, modifier, activer, cloner ou migrer des machines virtuelles compatibles avec ESX Server 2.x. Vous pouvez uniquement les enregistrer ou les mettre à niveau.

Le paramètre de compatibilité qui apparaît dans le menu déroulant Compatible avec est le paramètre par défaut de la machine virtuelle que vous créez. Les facteurs suivants déterminent la compatibilité par défaut de la machine virtuelle :

  • La version d'hôte ESXi sur lequel la machine virtuelle est créée.

  • L'objet d'inventaire sur lequel la compatibilité de la machine virtuelle par défaut est défini, y compris un hôte, un cluster ou un centre de données.

Vous pouvez accepter la compatibilité par défaut ou sélectionner un paramètre différent. Il n'est pas toujours nécessaire de sélectionner la version la plus récente de l'hôte ESXi. Le choix d'une version antérieure peut procurer davantage de flexibilité et est utile dans les situations suivantes :

  • Pour standardiser les tests et le déploiement dans l'environnement virtuel.

  • Si vous n'avez pas besoin des capacités de la version la plus récente.

  • Pour maintenir la compatibilité avec les anciens hôtes.

Lors de la création d'une machine virtuelle, tenez compte de l'environnement dans lequel la machine virtuelle va fonctionner et comparez les avantages de stratégies de compatibilité différentes. Tenez compte de vos options pour ces possibilités, qui montrent la flexibilité inhérente à chaque sélection de compatibilité de la machine virtuelle.

Objets dans l'environnement

Compatibilité

Résultats

Cluster avec hôtes ESXi 5.0 et ESXi 4.x

ESX/ESX 4.0 et versions ultérieures

Préserve la capacité de la machine virtuelle à fonctionner sur d'autres hôtes dans le cluster, comme ESXi 5.0.

Il est possible que vous n'ayez pas accès aux caractéristiques du matériel virtuel les plus récentes.

Cluster avec hôtes ESXi 5.0 et ESXi 4.x

ESXi 5.0 et versions ultérieures

Vous donne accès à des caractéristiques du matériel virtuel qui ne sont pas disponibles avec ESXi 4.x. Fonctionne également sur des hôtes ESXi 5.1 et ultérieurs.

  • Vous ne pouvez pas migrer cette machine virtuelle vers un hôte ESXi 4.x.

  • Cette machine virtuelle ne dispose pas de toutes les capacités des machines virtuelles fonctionnant sur ESXi 5.1. Il est par exemple impossible d'utiliser 64 processeurs virtuels.

Hôte ESXi 5.5

ESXi 5.5 et versions ultérieures

Donne accès aux fonctionnalités matérielles virtuelles les plus récentes, mais ne peut pas partager de ressources avec des hôtes plus anciens.

S'il n'est pas nécessaire que les machines virtuelles restent compatibles avec les versions d'hôte ESX/ESXi plus anciens, vous pouvez les mettre à niveau.

  • Pour maintenir la compatibilité des machines virtuelles avec les hôtes ESX/ESXi 3.5, mettez à niveau les machines virtuelles sur un hôte ESX/ESXi 3.5, ce qui permet d'effectuer une mise à niveau de machine virtuelle vers la version 4.

  • Pour maintenir la compatibilité des machines virtuelles avec les hôtes ESX/ESXi 4.x, mettez à niveau les machines virtuelles sur un hôte ESX/ESXi 4.x, ce qui permet d'effectuer une mise à niveau de machine virtuelle vers la version 7.