vCenter Server Appliance Component Manager échoue en générant une erreur lors de son premier déploiement après une mise à niveau.

Problème

Vous déployez une instance de vCenter Server Appliance et recevez une erreur de ce type :

Erreur d'exécution du script Firstboot.

« Le certificat SSL ne correspond pas lors de la connexion à vCenter Single Sign-On : nom d'hôte du certificat ne correspond pas : <vcenter-b.domain.com> != <localhost.localdom> OR <localhost.localdom> OR <localhost> »

Cause

Les noms d'instance de vCenter Server Appliance ne correspondent pas aux noms qui figurent dans les certificats SSL. Vous devez régénérer les certificats pour que les noms de domaine complets soient corrects.

Solution

  1. Démarrez l'instance de vCenter Server Appliance 5.5.
  2. Log into the VAMI https://IP:5480.
  3. Assurez-vous que l'adresse IP et le nom d'hôte corrects sont définis dans les paramètres réseau.
  4. Cochez la case Régénération de certificat.
  5. Redémarrez l'instance de vCenter Server Appliance 5.5.
    Les certificats vCenter Server, vSphere Web Client, vami, slapd, vCenter Inventory Service et vCenter Single Sign-On sont régénérés avec un certificat contenant CN=vcenter-a.domain.com et SubjectAltName contenant DNS=vcenter-a.domain.com DNS=vcenter-a IP= 192.168.2.100. Les certificats ne contiennent plus vcenter-b.domain.com.
  6. Réexécutez la mise à niveau de vCenter Server Appliance 6.5.

Solution

Reportez-vous à Mettre à niveau une instance de vCenter Server Appliance 5.5 ou 6.0 avec vCenter Single Sign-On intégré ou une instance de Platform Services Controller au moyen de l'interface utilisateur graphique.