Dans certains cas, la base de données vSphere Auto Deploy peut poser un problème. La solution de récupération la plus efficace consiste à remplacer le fichier de base de données existant par la dernière sauvegarde.

Problème

Lorsque vous utilisez vSphere Auto Deploy pour fournir les hôtes ESXi de votre environnement, vous pouvez être confronté à un problème avec la base de données vSphere Auto Deploy.
Important : Toutefois, cette situation est rare. Suivez toutes les autres stratégies de dépannage de vSphere Auto Deploy avant de remplacer le fichier de base de données actuel. Les règles et associations que vous avez créées depuis la sauvegarde que vous choisissez sont perdues.

Cause

Ce problème apparaît uniquement avec les hôtes provisionnés avec vSphere Auto Deploy.

Solution

  1. Arrêtez le service du serveur vSphere Auto Deploy.
  2. Trouvez les journaux vSphere Auto Deploy en accédant à la page vSphere Auto Deploy de vSphere Client.
  3. Recherchez les messages suivants dans le journal :
    Erreur de la base de données : l'image du disque de la base de données a subi une déformation.

    Si ce message existe, remplacez la base de données existante par la dernière sauvegarde.

  4. Accédez au répertoire de données vSphere Auto Deploy à l'adresse /var/lib/rbd.
    Le répertoire contient le fichier db et les fichiers de sauvegarde db- yyy- mm- dd.
  5. Renommez le fichier db actuel.
    Le support VMware peut vous demander ce fichier si vous appelez pour une assistance.
  6. Renommez la dernière sauvegarde en utilisant le nom db.
  7. Redémarrez le service du serveur vSphere Auto Deploy.
  8. Si le message figure toujours dans le journal, répétez les étapes en utilisant la dernière sauvegarde suivante jusqu'à ce que vSphere Auto Deploy ne génère plus d'erreurs de base de données.