Le programme d'installation de vCenter Single Sign-On affiche un message d'erreur relatif à vCenter Server ou à vSphere Client.
Problème
Les programmes d'installation de vCenter Server et Web Client affichent le message d'erreur Could not contact Lookup Service. Please check VM_ssoreg.log...
.
Cause
Ce problème a plusieurs causes, notamment des horloges non synchronisées sur les machines hôte, un blocage provenant du pare-feu et des services qui doivent être démarrés.
Solution
- Vérifiez si les horloges des ordinateurs hôte sur lesquels vCenter Single Sign-On, vCenter Server et Web Client sont actifs sont synchronisées.
- Consultez le journal spécifique qui figure dans le message d'erreur.
Dans le message, le dossier temporaire système se rapporte à
%TEMP%.
- Dans le fichier journal, recherchez les messages suivants.
Le fichier journal contient un sortie de toutes les tentatives d'installation. Recherchez le dernier message qui indique
Initializing registration provider...
Message |
Cause et solution |
java.net.ConnectException: Connection timed out: connect |
L'adresse IP est erronée, un pare-feu bloque l'accès à vCenter Single Sign-On, ou vCenter Single Sign-On est surchargé. Assurez-vous qu'un pare-feu ne bloque pas le port vCenter Single Sign-On (par défaut, 7444). Assurez-vous également que la machine sur laquelle est installé vCenter Single Sign-On dispose de capacités de CPU, d'E/S et de RAM suffisantes. |
java.net.ConnectException: Connection refused: connect |
L'adresse IP ou le nom de domaine complet est erroné(e) et le service vCenter Single Sign-On n'a pas démarré ou a démarré au cours de la minute écoulée. Vérifiez que vCenter Single Sign-On fonctionne en contrôlant l'état de vCenter Single Sign-On daemon vmware-sso. Redémarrez le service. Si le redémarrage ne résout pas le problème, consultez la section Récupération du Guide de dépannage de vSphere. |
Unexpected status code: 404. SSO Server failed during initialization |
Redémarrez vCenter Single Sign-On. Si le redémarrage ne résout pas le problème, consultez la section Récupération du Guide de dépannage de vSphere. |
L'erreur indiquée dans l'interface utilisateur commence par Could not connect to vCenter Single Sign-On |
Vous pouvez également voir le code de retour SslHandshakeFailed. Cette erreur indique que l'adresse IP ou le nom de domaine complet qui assure la résolution vers l'hôte vCenter Single Sign-On n'est pas l'adresse que vous avez utilisée pendant l'installation de vCenter Single Sign-On. Dans VM_ssoreg.log, recherchez la ligne qui contient le message suivant. host name in certificate did not match: <install-configured FQDN or IP> != <A> or <B> or <C> où A était le nom de domaine complet que vous avez entré lors de l'installation de vCenter Single Sign-On et B et C sont des alternatives admissibles générées par le système. Corrigez la configuration pour utiliser le nom de domaine complet à droite du signe != dans le fichier journal. Dans la plupart des cas, utilisez le nom de domaine complet que vous avez spécifié pendant l'installation de vCenter Single Sign-On. Si aucune des alternatives n'est possible dans votre configuration réseau, récupérez votre configuration vCenter Single Sign-On SSL. |