Il est essentiel de pouvoir accéder à la banque de données des métadonnées Fault Tolerance pour assurer le bon fonctionnement d'une machine virtuelle FT. La perte de cet accès peut provoquer toute une série de problèmes.
Problème
- FT peut s'arrêter de manière inattendue.
- Si ni la machine virtuelle principale, ni la secondaire ne peut accéder à la banque de données des métadonnées, les machines virtuelles peuvent échouer de manière inattendue. En général, un échec isolé provoquant l'arrêt de FT se produit également lorsque les deux machines virtuelles perdent l'accès à la banque de données des métadonnées FT. vSphere HA tente ensuite de redémarrer la machine virtuelle principale sur un hôte disposant d'un accès à la banque de données des métadonnées.
- La machine virtuelle peut ne plus être reconnue comme une machine virtuelle FT par vCenter Server. Cet échec de reconnaissance peut autoriser certaines opérations non prises en charge, telles que la création de snapshots sur la machine virtuelle, ce qui peut entraîner des problèmes de fonctionnement.
Cause
L'absence d'autorisations d'accès à la banque de données des métadonnées de Fault Tolerance peut conduire à des résultats indésirables dans la liste précédente.
Solution
Lors de la planification de votre déploiement FT, placez la banque de données des métadonnées sur un stockage à haut niveau de disponibilité. Lorsque FT est en cours d'exécution, si vous ne parvenez pas à accéder à la banque de données des métadonnées sur la machine virtuelle principale ou secondaire, traitez rapidement le problème de stockage avant que la perte de l'accès provoque l'un des problèmes précédents. Si une machine virtuelle n'est plus reconnue comme une machine virtuelle FT par vCenter Server, n'effectuez aucune opération non prise en charge sur la machine virtuelle. Restaurez l'accès à la banque de données des métadonnées. Après le rétablissement de l'accès aux machines virtuelles FT et à la fin de la période d'actualisation, les machines virtuelles sont reconnaissables.