Après avoir mis à niveau l’hôte ESXi vers une version plus récente, la console de navigateur peut afficher un message d'erreur lorsque vous tentez d'accéder à l’hôte ESXi à l'aide de VMware Host Client, et la connexion peut échouer.

Problème

Après avoir mis à niveau votre hôte ESXi vers une version plus récente, la tentative d'accès à https://host-fqdn/ui ou https://1.2.3.4/ui risque de générer l'erreur suivante :
503 Service indisponible (Échec de la connexion au point de terminaison : [N7Vmacore4Http16LocalServiceSpecE:0xffa014e8] _serverNamespace = /ui _isRedirect = false _port = 8308)

Cause

La modification en /etc/vmware/rhttpproxy/endpoints.conf demeure après la mise à niveau et entraîne le remplacement de VMware Host Client par /ui.

Lorsque /ticket est manquant dans le fichier endpoint.conf sur votre hôte ESXi 6.0 ou une version ultérieure, votre machine virtuelle dans le navigateur affiche le message d'erreur Échec de la connexion mais VMware Remote Console continue de fonctionner.

Solution

  1. Connectez-vous à votre hôte ESXi en utilisant SSH ou l'interpréteur de commandes ESXi.
    Si vous utilisez SSH, vous devrez peut-être commencer par activer SSH. Vous pouvez activer SSH à l'aide de DCUI.
  2. Sauvegardez le fichier endpoints.conf.
    cp /etc/vmware/rhttpproxy/endpoints.conf /tmp
  3. Ouvrez le fichier /etc/vmware/rhttpproxy/endpoints.conf dans un éditeur et supprimez la ligne suivante.
    /ui local 8308 redirect  allow
  4. Redémarrez le serveur de gestion de configuration rhttpproxy.
    /etc/init.d/rhttpproxy restart
  5. Accédez à VMware Host Client en utilisant le nom complet spécifié pour l'hôte dans l'URL sécurisée avec https://host-fqdn/ui ou une adresse IP numérique valide https://1.2.3.4/ui.