Avant d'ajouter ou de supprimer l'hôte témoin dans un cluster étendu vSAN, tous les hôtes actuels doivent être connectés. Si un hôte actuel est déconnecté, vous ne pouvez pas ajouter ou supprimer l'hôte témoin.

Problème

Lorsque vous ajoutez ou supprimez un hôte témoin dans un cluster étendu vSAN dans lequel certains hôtes sont déconnectés, l'opération échoue avec un état d'erreur : L'opération n'est pas autorisée dans l'état actuel. Les hôtes du cluster ne sont pas tous connectés à Virtual Center.

Cause

Lorsque l'hôte témoin rejoint ou quitte un cluster étendu, vSAN doivent mettre à jour la configuration sur tous les hôtes dans le cluster.  Si un ou plusieurs hôtes sont déconnectés de vCenter Server, l'hôte témoin ne peut pas être ajouté ou supprimé.

Solution

Vérifiez que tous les hôtes sont connectés à vCenter Server, et recommencez l'opération. Si vous ne pouvez pas rejoindre l'hôte déconnecté, supprimez l'hôte déconnecté du cluster, et ensuite, vous pouvez ajouter ou supprimer l'hôte témoin.