Lorsque vous tentez de déployer une machine virtuelle dans un cluster vSAN, l'opération échoue avec une erreur indiquant que les fichiers de la machine virtuelle ne peuvent pas être créés.

Problème

L'opération de création d'une machine virtuelle échoue avec un état d'erreur : Impossible d'effectuer l'opération de création du fichier.

Cause

Le déploiement d'une machine virtuelle sur vSAN peut échouer pour plusieurs raisons.

  • vSAN ne peut pas allouer d'espace pour les stratégies de stockage de la machine virtuelle et les objets de la machine virtuelle. Une telle panne peut se produire si la banque de données n'a pas une capacité utile suffisante, par exemple si un disque physique est temporairement déconnecté de l'hôte.
  • La machine virtuelle a des disques virtuels de très grande taille et les hôtes du cluster ne peuvent pas leur fournir un stockage sur la base des règles de placement dans la stratégie de stockage de VM

    Par exemple, si le Niveau primaire de pannes à tolérer dans la stratégie de stockage de VM est défini sur 1, vSAN doit stocker deux réplicas d'un disque virtuel dans le cluster, un réplica par hôte. La banque de données peut avoir cet espace après avoir regroupé l'espace libre sur tous les hôtes du cluster. Toutefois, deux hôtes ne peuvent pas être disponibles dans le cluster, chacun fournissant suffisamment d'espace pour stocker une réplique distincte du disque virtuelle.

    vSAN ne déplace pas de composants entre les hôtes ou les groupes de disques pour libérer de l'espace pour un nouveau réplica, même si le cluster peut contenir assez d'espace pour provisionner la nouvelle machine virtuelle.

Solution

  • Vérifiez l'état des périphériques de capacité dans le cluster.
    1. Accédez au cluster vSAN.
    2. Dans l'onglet Surveiller, cliquez sur vSAN et sélectionnez Disques physiques.
    3. Examinez la capacité et l'état de santé des périphériques sur les hôtes du cluster.