Pour surveiller tous les hôtes de votre environnement vSphere à partir d'un emplacement unique et simplifier la configuration des hôtes, connectez les hôtes à un système vCenter Server.

Pour plus d'informations sur la gestion de la configuration des hôtes ESXi, reportez-vous aux documentations Mise en réseau vSphere, Stockage vSphere et Sécurité vSphere.

Mettre à jour votre environnement VMware Host Client vers la dernière version

Pour déterminer si vous utilisez la dernière version de VMware Host Client, vérifiez que les VIB (bundles d'installation vSphere) sont installés dans votre environnement et examinez les informations sur la version des VIB. Vous pouvez mettre à jour votre environnement VMware Host Client en entrant une URL ou un chemin de banque de données vers un VIB ou vers le fichier metadata.zip dans un module de bundle hors ligne ESXi.

Si vous fournissez un fichier VIB, un VIB existant qui est installé sur votre environnement VMware Host Client est mis à jour avec le nouveau VIB.

Si vous fournissez un bundle hors ligne, vous mettez à jour l'intégralité de l'hôte ESXi vers la version décrite par le fichier metadata.zip du bundle. Assurez-vous que l'intégralité du bundle hors ligne est disponible via l'URL ou chargée dans la banque de données.

Procédure

  • Pour mettre à jour votre environnement vers la dernière version, effectuez les tâches suivantes :
    Tâche Étapes
    Télécharger un VIB vers une banque de données
    1. Dans l'environnement VMware Host Client, cliquez sur Stockage.
    2. Sélectionnez une banque de données dans la liste et cliquez sur Navigateur de banque de données.
    3. Pour stocker le VIB, sélectionnez un répertoire et cliquez sur Télécharger.
    4. Accédez à l'emplacement du fichier et double-cliquez sur celui-ci.
    Télécharger un bundle hors ligne vers une banque de données
    1. Téléchargez le module de bundle hors ligne ESXi.
    2. Chargez le module de bundle hors ligne ESXi sur l'hôte ESXi. Vous pouvez charger le module de bundle hors ligne à l'aide du Navigateur de banque de données, du protocole de copie sécurisée ou de WinSCP.
    3. Extrayez le contenu du bundle hors ligne sur l'hôte ESXi. Par exemple, connectez-vous à l’hôte à l’aide de SSH.
    4. Accédez au répertoire dans lequel vous avez téléchargé le bundle hors ligne.
    5. Extrayez le contenu à l'aide de la commande
      unzip
      .
    Mettre à jour votre environnement
    1. Cliquez sur Gérer dans VMware Host Client, et cliquez sur Packages.
    2. Cliquez sur Installer la mise à jour et entrez l'URL ou le chemin de banque de données vers un VIB ou un fichier metadata.zip dans un bundle hors ligne.
    3. Cliquez sur Mise à niveau.
      Attention : Si vous mettez à jour un hôte ESXi géré par vSphere Lifecycle Manager, l'hôte peut devenir non conforme.
    4. Cliquez sur Actualiser pour vous assurer que la mise à jour est effectuée.

Impossible de se connecter depuis VMware Host Client à un hôte ESXi après la mise à niveau vers une version plus récente de ESXi

Après avoir mis à niveau l’hôte ESXi vers une version plus récente, la console de navigateur peut afficher un message d'erreur lorsque vous tentez d'accéder à l’hôte ESXi à l'aide de VMware Host Client, et la connexion peut échouer.

Problème

Après avoir mis à niveau votre hôte ESXi vers une version plus récente, la tentative d'accès à https://host-fqdn/ui ou https://1.2.3.4/ui risque de générer l'erreur suivante :
503 Service indisponible (Échec de la connexion au point de terminaison : [N7Vmacore4Http16LocalServiceSpecE:0xffa014e8] _serverNamespace = /ui _isRedirect = false _port = 8308)

Cause

La modification en /etc/vmware/rhttpproxy/endpoints.conf demeure après la mise à niveau et entraîne le remplacement de VMware Host Client par /ui.

Lorsque /ticket est manquant dans le fichier endpoint.conf sur votre hôte ESXi 6.0 ou une version ultérieure, votre machine virtuelle dans le navigateur affiche le message d'erreur Échec de la connexion mais VMware Remote Console continue de fonctionner.

Solution

  1. Connectez-vous à votre hôte ESXi en utilisant SSH ou l'interpréteur de commandes ESXi.
    Si vous utilisez SSH, vous devrez peut-être commencer par activer SSH. Vous pouvez activer SSH à l'aide de DCUI.
  2. Sauvegardez le fichier endpoints.conf.
    cp /etc/vmware/rhttpproxy/endpoints.conf /tmp
  3. Ouvrez le fichier /etc/vmware/rhttpproxy/endpoints.conf dans un éditeur et supprimez la ligne suivante.
    /ui local 8308 redirect  allow
  4. Redémarrez le serveur de gestion de configuration rhttpproxy.
    /etc/init.d/rhttpproxy restart
  5. Accédez à VMware Host Client en utilisant le nom complet spécifié pour l'hôte dans l'URL sécurisée avec https://host-fqdn/ui ou une adresse IP numérique valide https://1.2.3.4/ui.

Accéder à vSphere Client

Pour accéder à l'ensemble des fonctionnalités et aux fonctionnalités administratives et de dépannage avancées de l'hôte ESXi, connectez l'hôte ESXi à vCenter Server.

Procédure

  1. Cliquez avec le bouton droit sur Hôte dans l'inventaire VMware Host Client et sélectionnez Gérer avec vCenter Server dans le menu déroulant.
    La page de connexion vCenter Server s'ouvre dans une nouvelle fenêtre.
  2. Entrez vos informations d'identification et cliquez sur Connexion.

Déconnecter un hôte ESXi de vCenter Server avec VMware Host Client

Si vous ne souhaitez plus utiliser les fonctionnalités avancées fournies par vCenter Server pour la gestion des hôtes, ou si vCenter Server a échoué et que vous devez effectuer des opérations d'urgence sur l'hôte, vous pouvez déconnecter votre hôte ESXi de vCenter Server.

Déconnecter un hôte ESXi peut prendre plusieurs minutes.

Procédure

  1. Cliquez avec le bouton droit sur Hôte dans l'inventaire VMware Host Client et sélectionnez Déconnecter de vCenter Server dans le menu contextuel.
    Note : La déconnexion d'un hôte informe vCenter Server que cet hôte ne répond pas.
  2. Cliquez sur Déconnecter de vCenter Server.