Vous devrez peut-être ré-enregistrer l'OIDC vCenter Server avec NSX Manager dans certaines situations, par exemple lorsque le nom de domaine complet/PNID de vCenter Server change.
Procédure
Impossible de modifier le mot de passe du dispositif NSX
Ils se peut que vous puissiez ne pas modifier le mot de passe du dispositif NSX pour les utilisateurs root
, admin
ou audit
.
Problème
Les tentatives de modification du mot de passe du dispositif NSX pour les utilisateurs de root
, de admin
ou de audit
. via vSphere Client peuvent échouer.
Cause
Pendant l'installation de NSX Manager, la procédure n'accepte qu'un seul mot de passe pour les trois rôles. Les tentatives de modification de ce mot de passe peuvent échouer ultérieurement.
Solution
- ♦ Utilisez les NSX API pour modifier les mots de passe.
Pour plus d'informations, reportez-vous à https://kb.vmware.com/s/article/70691 et au Guide d'administration de NSX.
Dépannage des workflows ayant échoué et des dispositifs NSX Edge instables
Si vos workflows échouent ou si les dispositifs NSX Edge sont instables, vous pouvez effectuer une procédure de dépannage.
Problème
Lorsque vous modifiez la configuration du groupe de ports distribués sur vSphere Client, les workflows peuvent échouer et les dispositifs NSX Edge peuvent devenir instables.
Cause
La suppression ou la modification des groupes de ports distribués pour la superposition et la liaison montante qui ont été créés lors de la configuration du cluster NSX Edge au cours de la configuration du cluster n'est pas autorisée en raison de leur conception.
Solution
Si vous devez modifier la configuration du VLAN ou du pool d'adresses IP de dispositifs NSX Edge, vous devez d'abord supprimer les éléments de NSX et la configuration de vSphere IaaS control plane du cluster.
Pour plus d'informations sur la suppression des éléments de NSX, reportez-vous au Guide d'installation de NSX.
Collecter des bundles de support pour le dépannage de NSX
Vous pouvez collecter des bundles de support sur des nœuds de cluster et d'infrastructure enregistrés pour le dépannage et télécharger les bundles sur votre machine ou les télécharger vers un serveur de fichiers.
Si vous choisissez de télécharger les bundles sur votre machine, vous obtenez un fichier d'archive unique constitué d'un fichier de manifeste et de bundles de support pour chaque nœud. Si vous choisissez de télécharger les bundles sur un serveur de fichiers, le fichier manifeste et les bundles individuels sont téléchargés sur le serveur de fichiers séparément.
Procédure
Collecter des fichiers journaux pour NSX
Vous pouvez collecter les journaux qui se trouvent dans les composants vSphere IaaS control plane et NSX pour détecter et résoudre les erreurs. Ces fichiers journaux peut être demandée par le support VMware.
Procédure
- Connectez-vous à vCenter Server en utilisant vSphere Client.
- Collectez les fichiers journaux suivants.
Fichier journal Description /var/log/vmware/wcp/wcpsvc.log Contient des informations relatives à l'activation de vSphere IaaS control plane. /var/log/vmware/wcp/nsxd.log Contient des informations relatives à la configuration des composants NSX. - Connectez-vous à NSX Manager.
- Collectez le fichier /var/log/proton/nsxapi.log pour plus d'informations sur l'erreur que NSX Manager renvoie lorsqu'une opération vSphere IaaS control plane spécifique a échoué.
Redémarrer le service WCP si le certificat, l'empreinte numérique ou l'adresse IP de gestion NSX est modifié
Si le certificat, l'empreinte numérique ou l'adresse IP de gestion NSX est modifié après l'installation de vSphere IaaS control plane, vous devez redémarrer le service WCP
.
Redémarrer le service vSphere IaaS control plane si le certificat NSX est modifié
Le fonctionnement actuel de vSphere IaaS control plane nécessite que, si le certificat NSX, l'empreinte numérique ou l'adresse IP NSX est modifié, vous devez redémarrer le service WCP
pour que la modification prenne effet. Si une modification se produit sans redémarrage du service, la communication entre vSphere IaaS control plane et NSX échoue, et certains symptômes peuvent se produire (par exemple, NCP entre dans une étape CrashLoopBackoff ou les ressources de Superviseur deviennent non déployables).
WCP
, utilisez la commande
vmon-cli
.
- Ouvrez une session SSH sur vCenter Server et connectez-vous en tant qu'utilisateur racine.
- Exécutez la commande
shell
. - Exécutez la commande
vmon-cli -h
pour afficher la syntaxe d'utilisation et les options. - Exécutez la commande
vmon-cli -l
pour afficher le processuswcp
.Le service
wcp
apparaît au bas de la liste. - Exécutez la commande
vmon-cli --restart wcp
pour redémarrer le servicewcp
.Le message suivant s'affiche :
Completed Restart service request
. - Exécutez la commande
vmon-cli -s wcp
et vérifiez que le servicewcp
est démarré.Par exemple :root@localhost [ ~ ]# vmon-cli -s wcp Name: wcp Starttype: AUTOMATIC RunState: STARTED RunAsUser: root CurrentRunStateDuration(ms): 22158 HealthState: HEALTHY FailStop: N/A MainProcessId: 34372