La tentative de mise à niveau d'un proxy cloud existant pour une utilisation avec un compte de cloud vRealize Automation Cloud échoue avec une erreur d'accès au manifeste.

Problème

Vous pouvez mettre à niveau un proxy cloud configuré existant, plutôt que de créer et de configurer un nouveau proxy cloud, pour un compte de cloud vRealize Automation Cloud nouveau ou existant. Toutefois, la mise à niveau peut échouer avec le message d’erreur suivant ou similaire.
Details
Checking for available updates, this process can take a few minutes ...
Failure: Error downloading manifest. Please contact your vendor.  
The requested URL returned error: 404 Not Found URL: <https:// ...>

Cause

Certaines informations requises par le processus de mise à niveau peuvent être manquantes dans le fichier manifeste /opt/vmware/var/lib/vami/update/provider/provider-runtime.xml qui a été utilisé lors de la configuration du proxy cloud.
Note : Ce problème de fichier manifeste a été résolu dans les versions plus récentes de vRealize Automation Cloud. Cependant, si vous utilisez un proxy cloud de version antérieure et que vous recevez le message d'erreur cité, utilisez cette solution pour mettre à niveau le fichier manifeste provider-runtime.xml du proxy cloud.

Solution

  1. Localisez et examinez le fichier manifeste du proxy cloud. Un exemple de fichier /opt/vmware/var/lib/vami/update/provider/provider-runtime.xml est présenté ci-dessous :
    <service>
      <properties>
         <property name="jobId" value="1" />_
         <property name="jobList" value='{ "Check":{ "JobStatus": "Failed", "JobState": 8, "TimeOfLastStateChange": "20210120101111.982008+000", "ErrorCode": 20, "ErrorDescription": "Error downloading manifest. Please contact your vendor. The requested URL returned error: 404 Not Found URL: https:\/\/vapp-updates.vmware.com\/vai-catalog\/valm\/vmw\/a1ba78af-ec67-4333-8e25-a4be022f97c7\/7.2.0.33184.latest\/manifest\/manifest-latest.xml", "TimeBeforeRemoval": "00000000000500.000000:000", "TimeSubmitted": "20210120101031.385064+000", "InstanceID": "VMware-VAMI:Job_1" }}' />_
      </properties>
    </service>
  2. Si le fichier contient un contenu semblable au contenu ci-dessus, mettez-le à jour manuellement avec le contenu suivant :
    <service>
        <properties>
            <property name="localRepositoryAddress" value="https://ci-data-collector-sandbox.s3.amazonaws.com/upgrade" />
            <property name="localRepositoryPasswordFormat" value="base64" />
        </properties>
    </service>
  3. Redémarrez le proxy cloud sur l'instance de vCenter Server.
  4. Exécutez le même processus de mise à niveau du proxy cloud que celui que vous avez exécuté précédemment et qui a généré l'erreur mentionnée ci-dessus.
  5. Si l’erreur persiste, contactez le support VMware.