vRealize Business for Cloud ne collecte pas de données en raison d'une panne dans le processus de calcul du coût vCenter Server.

Problème

  • Le message d'échec de calcul du coût de stockage s'affiche dans le menu Statut de vCenter Server.
  • Le service de stockage vCenter Server peut échouer. Dans ce cas, les profils de stockage ne figurent pas dans vRealize Business for Cloud.

Cause

Ce problème peut se produire dans l'une des situations suivantes :

  • Les services Web de gestion (WS-Management) ne sont pas en cours d'exécution sur vCenter Server.
  • L'utilisateur de vCenter Server ne dispose pas de tous les privilèges suivants :
    • Privilèges Storage views.View et Profile-driven storage.Profile-driven storage view.
    • Si vCenter Server est intégré à vRealize Operations Manager, l'utilisateur doit disposer du privilège Global.vCenter Operations User.
  • Le service Stockage basé sur le profil n'est pas en cours d'exécution dans vCenter Server.
  • Les services Web et les services basés sur le profil de vCenter Server ne s'exécutent pas sous le même compte LocalSystem ou le même compte de domaine.
  • Pour le dispositif virtuel vCenter Server, le correctif OpenSSL contre la faille de sécurité Heartbleed est appliqué, mais les certificats du service de surveillance du stockage vCenter ne sont pas mis à niveau.
  • Problèmes de base de données dans vCenter Server.

Solution

Pour plus informations sur les étapes à effectuer dans vCenter Server pour résoudre ces problèmes, reportez-vous aux articles de la base de connaissances KB2060967, KB2076692, KB2015180.

Procédure

  1. Corrigez les problèmes de surveillance des services, de privilèges d'utilisateur ou de base de données dans vCenter Server.