vRealize Business for Cloud ne parvient pas à collecter des données à partir de vCenter Server.
Problème
Lorsque vous cliquez sur Statut dans l'interface utilisateur de vRealize Business for Cloud, l'un des problèmes suivants se produit :
Vous voyez l'icône rouge de statut de vCenter Server.
Un message d'échec de synchronisation de vCenter Server s'affiche.
Le message d'erreur suivant s'affiche dans la section vCenter Server :
Unable to retrieve data from vROps vrops_server_address
Lorsque vous cliquez sur Statut dans l'interface utilisateur de vRealize Business for Cloud, le message d'erreur suivant s'affiche dans vCenter Server :
Unable to authenticate to vROps vrops_server_address using the vCenter's credentials
Cause
Ce problème peut se produire dans l'une des situations suivantes :
Le fuseau horaire du dispositif virtuel vRealize Business for Cloud n'est pas au format UTC.
Les services Web et les services basés sur le profil de vCenter Server ne s'exécutent pas dans le même compte LocalSystem ou le même compte de domaine.
Le serveur vRealize Operations Manager est inaccessible.
Le service d'API vRealize Operations Manager est en échec.
Le serveur vRealize Operations Manager se trouve dans un environnement en cluster HA à plusieurs nœuds et le nœud enregistré dans vCenter Server est inaccessible.
La connexion de l'utilisateur vCenter Server individuel est désactivée dans vRealize Operations Manager.
Solution
Pour plus d'informations, reportez-vous à l'article de la base de connaissances à l'adresse http://kb.vmware.com/kb/2146836.
Procédure
- Pour résoudre ce problème, utilisez la procédure appropriée parmi les solutions suivantes.
Dans la machine virtuelle vRealize Business for Cloud, remplacez le format de fuseau horaire actuel par le format UTC et exécutez la commande
monit restart itbm-server
.Assurez-vous que tous les services de vCenter Server tels que l'inventaire, les statistiques et les profils de stockage s'exécutent sous le même compte d'utilisateur.
Si vCenter Server a été ajouté à vRealize Operations Manager au cours des dernières 24 heures, attendez que vRealize Operations Manager calcule toutes les données avant de réessayer d'effectuer la collecte de données.
Recherchez d'éventuels problèmes avec le service d'API de vRealize Operations Manager et résolvez-les.
Si l'instance de vRealize Operations Manager est une configuration à plusieurs nœuds et si un nouveau nœud a été déployé pour remplacer le nœud ayant échoué, mettez à jour le plug-in sur vRealize Operations Manager pour enregistrer le nouveau nœud dans vCenter Server.
Activez le journal individuel en option dans l'instance de vRealize Operations Manager.
Cliquez sur
.