vRealize Business for Cloud signale un stockage insuffisant pour les factures de Cloud grand public.

Problème

Si la taille du fichier décompressé de la facture AWS ou Azure est importante, le dispositif virtuel ne dispose plus de suffisamment de stockage et ne parvient pas à stocker la facture.

Cause

Ce problème se produit lorsque le fichier décompressé de la facture AWS ou Azure est volumineux. Le manque d'espace disque affecte le processus de collecte de données et les autres processus ayant besoin d'accéder au stockage.

Solution

  1. Arrêtez le dispositif vRealize Business for Cloud.
  2. Ajoutez un nouveau disque dur au dispositif vRealize Business for Cloud.
  3. Mettez le dispositif virtuel sous tension.
  4. Connectez-vous au dispositif virtuel à l'aide de Secure Sockets Layer.
  5. Dans le client shell, exécutez fdisk-lu pour répertorier tous les disques et identifier l'ID de périphérique du nouveau disque ajouté.
    Note:

    Par défaut, l'ID de périphérique du nouveau disque est /dev/sdb.

  6. Accédez à l'utilitaire de disque du nouveau disque et exécutez la commande fdisk/dev/sdb.
    1. Appuyez sur N, puis sur Entrée pour accéder à la nouvelle partition.
    2. Appuyez sur P, puis sur Entrée pour accéder à la partition principale.
    3. Appuyez sur 1, le numéro de partition.
    4. Acceptez les valeurs par défaut de début et de fin de bloc (utilisez la valeur par défaut en cliquant deux fois sur Entrée, une fois pour la valeur par défaut de début et une fois pour celle de fin).
    5. Appuyez sur W pour écrire la table de partition sur le disque.
    6. Créez une partition sur le nouveau disque.
  7. Pour créer un système de fichiers ext3 sur le nouveau disque, exécutez mkfs -t ext3 /dev/sdb1.
  8. Si la taille de la facture d'AWS ou d'Azure est importante, exécutez mount /dev/sdb1 /usr/local/tomcat/itbm-data-collector/temp/ pour monter le collecteur de données dans un emplacement temporaire sur le nouveau disque.
  9. Exécutez la commande mount -l.

    La commande confirme si la nouvelle partition est montée correctement ou non. Vérifiez si la sortie contient ou non /dev/sdb1 on /usr/local/tomcat/itbm-data-collector/temp type ext3 (rw,relatime,data=ordered).

  10. Pour ouvrir le fichier à l'aide de la commande vi, exécutez vi /etc/fstab.
  11. Ajoutez /dev/sdb1 /usr/local/tomcat/itbm-data-collector/temp ext3 defaults 1 1.

    Cette étape garantit que le disque n'est pas démonté en cas de redémarrage du dispositif virtuel.

Solution

Augmentez la taille du dispositif virtuel vRealize Business for Cloud.