Un message d'erreur s'affiche après l'enregistrement de vRealize Business for Cloud dans vRealize Automation.

Problème

Après l'enregistrement de vRealize Business for Cloud dans vRealize Automation, si vous accédez à Administration > Gestion professionnelle, un message d'erreur java.net.NoRouteToHostException : aucun itinéraire vers l'hôte s'affiche.

Cause

Ce problème se produit si l'adresse IP du dispositif virtuel vRealize Business for Cloud change après l'enregistrement de vRealize Business for Cloud dans vRealize Automation.

Solution

Pour en savoir plus sur la recréation de keystore SSL, consultez la section Modifier ou remplacer le certificat SSL de vRealize Business for Cloud du Guide d'installation.

Pour plus d'informations sur l'enregistrement de vRealize Business for Cloud, consultez la section Enregistrer vRealize Business for Cloud dans vRealize Automation du Guide d'installation.

Procédure

  1. Annulez l'enregistrement de vRealize Business for Cloud.
    1. Connectez-vous à la console Web vRealize Business for Cloud à l'adresse https://vRealize_Business_for_Cloud_IP_address:5480.
    2. Selon votre installation enregistrée, effectuez les étapes applicables.

      Option

      Procédure

      Dans le cas d'un enregistrement dans vRealize Automation

      1. Téléchargez tous les rapports vRealize Automation. Pour plus d'informations, consultez https://kb.vmware.com/s/article/2151835.

      2. Sous l'onglet Enregistrement, cliquez sur vRealize Automation.

      3. Entrez les détails du serveur vRealize Automation déjà enregistré.

      4. Cliquez sur Désinscrire.

      Si tous les paramètres sont corrects, le message Désinscrit du serveur vRealize Automation s'affiche.

      Dans le cas d'un enregistrement dans VMware Identity Manager

      1. Sous l'onglet Enregistrement, cliquez sur vIDM.

      2. Entrez les détails du dispositif virtuel VMware Identity Manager déjà enregistré.

      3. Cliquez sur Désinscrire.

      Si tous les paramètres sont corrects, le message Désinscrit du vIDM s'affiche.

  2. Exécutez l'une des étapes suivantes.
    • Supprimez le dispositif virtuel vRealize Business for Cloud de votre environnement et déployez une nouvelle instance de vRealize Business for Cloud avec une adresse IP statique et un nom de domaine complet.

    • Recréez le fichier du magasin de clés SSL (ssl.keystore).

  3. Enregistrez vRealize Business for Cloud dans vRealize Automation.