Le processus de définition des données implique l'ajout de propriétés, de mesures, de stratégies ou de données fournies par des adaptateurs à une vue. C'est grâce à ces éléments que vRealize Operations Manager collecte, calcule et présente les informations pour la vue.

Pour ajouter des données à une vue, sélectionnez Contenu > Vues dans le volet de gauche. Dans la barre d'outils Vues, cliquez sur le signe plus pour ajouter une vue ou sur le crayon pour modifier une vue sélectionnés. Dans l'espace de travail, à gauche, cliquez sur Données. Si vous créez une nouvelle vue, complétez les étapes précédentes requises.

Ajout de données à une vue

Si vous avez sélectionné plusieurs sujets, précisez pour lequel vous ajoutez des données. Double-cliquez sur les données de l'arborescence dans le volet de gauche pour les ajouter à la vue. Pour chaque sujet, les données à ajouter peuvent être différentes.

Configuration de la transformation des données

Les options de configuration des données disponibles dépendent de la vue et du type de données que vous sélectionnez. La plupart des options sont disponibles pour toutes les vues.

Tableau 1. Options de configuration des données

Option de configuration

Description

Nom de la mesure

Nom de la mesure par défaut.

Disponible pour toutes les vues.

Étiquette de la mesure

Étiquette personnalisable apparaissant dans la vue ou le rapport.

Disponible pour toutes les vues.

Unités

Dépend de la mesure ou de la propriété. Vous pouvez sélectionner l'unité à utiliser avec les valeurs. Par exemple, pour CPU|Demande (MHz), dans le menu déroulant Unités, vous pouvez sélectionner les unités Hz, KHz ou GHz. Si vous sélectionnez Auto, une unité pertinente sera automatiquement sélectionnée.

Disponible pour toutes les vues.

Ordre de tri

Trie les valeurs par ordre croissant ou décroissant.

Disponible pour les vues Liste et Résumé.

Transformation

Détermine la méthode de calcul à appliquer aux données brutes. Vous pouvez sélectionner le type de transformation :

  • Minimum. La valeur minimum de la mesure sur la plage de temps sélectionnée.

  • Maximum. La valeur maximum de la mesure sur la plage de temps sélectionnée.

  • Moyenne. La moyenne de toutes les valeurs de la mesure sur la plage de temps sélectionnée.

  • Somme. La somme de toutes les valeurs de la mesure sur la plage de temps sélectionnée.

  • Dernières. Ignore toutes les données à l'exception des dernières données reçues et ce, dans la plage de temps sélectionnée.

  • Écart type. L'écart type des valeurs de mesure.

  • Corrélation de mesure. Affiche la valeur lorsqu'un autre mesure est au minimum ou au maximum. Par exemple, affiche la valeur de memory.usage lorsque cpu.usage est au maximum.

  • Prévision. Effectue une analyse régressive et prédit les valeurs à venir. Affiche la dernière valeur de mesure de la plage sélectionnée.

Disponible pour toutes les vues, sauf Tendances.

Série de données

Vous pouvez choisir d'inclure les données historiques, les tendances des données historiques, ainsi que les prévisions dans les calculs de la vue de tendances.

Disponible pour la vue Tendances.

Cumul de la série

Intervalle de temps du cumul des données. Sélectionnez l'une des options disponibles. Par exemple, si vous sélectionnez Sum en tant que transformation et définissez l'intervalle de cumul sur 5 minutes, le système sélectionne des valeurs d'intervalle de 5 minutes et les ajoute.

Cette option s'applique à l'option de configuration Transformation.

Disponible pour toutes les vues.

Projets

Un projet contient des scénarios et une hypothèse permettant de déterminer le degré de modification de la capacité et de la charge qu'entraînerait la modification de certaines conditions, sans qu'il soit nécessaire de modifier votre infrastructure virtuelle. Si vous mettez en œuvre le projet, vous savez d'avance quels sont vos besoins en capacité.

Disponible pour toutes les vues. Dépend des mesures et des propriétés sélectionnées.

Configuration des paramètres de l'heure

Utilisez les paramètres de l'heure pour sélectionner l'intervalle de temps de transformation des données. Ces options sont disponibles pour tous les types de vues, à l'exception de l'image.

Vous pouvez définir une plage de temps pour une période passée ou définir une date ultérieure pour la fin de la période. Lorsque vous sélectionnez une date future de fin et qu'aucune donnée n'est disponible, la vue est renseignée avec des données de prévisions.

Tableau 2. Options des paramètres de temps

Option de configuration

Description

Mode d'intervalle de temps

En mode de base, vous pouvez sélectionner des intervalles de dates.

En mode avancé, vous pouvez sélectionner toute combinaison de dates relatives ou de dates de début et de fin spécifiques.

Plage de dates relative

Sélectionnez une plage de dates relatives de transformation des données.

Disponible en mode de base.

Plage de dates spécifiques

Sélectionnez une plage de dates spécifiques de transformation des données.

Disponible en mode de base.

Plage de dates absolues

Sélectionnez une plage de dates ou de temps pour afficher les données d'une unité de temps comme une semaine complète ou un mois complet. Par exemple, vous pouvez exécuter un rapport le troisième jour de chaque mois pour le mois précédent. Les données du premier au dernier jour du mois précédent s'affichent, tout comme les données du troisième jour du mois précédent au troisième jour du mois en cours.

Les unités de temps disponibles sont les suivantes : Heures, Jours, Semaines, Mois et Années.

Les paramètres régionaux du système déterminent le début et la fin de l'unité. Par exemple, dans la plupart des pays européens, la semaine commence le lundi tandis qu'aux États-Unis, elle commence le dimanche.

Disponible en mode de base.

Date de début relative

Sélectionnez une date de début relative de transformation des données.

Disponible en mode avancé.

Date de fin relative

Sélectionnez une date de fin relative de transformation des données.

Disponible en mode avancé.

Date de début spécifique

Sélectionnez une date de début spécifique de transformation des données.

Disponible en mode avancé.

Date de fin spécifique

Sélectionnez une date de fin spécifique de transformation des données.

Disponible en mode avancé.

Plage de dates sélectionnée

Affiche la plage de dates ou de temps que vous avez sélectionnée. Par exemple, si vous sélectionnez une plage de dates spécifique située entre le 01/05/2016 et le 18/05/2016, voici ce qui s'affiche : May 1, 2016 12:00:00 AM to May 18, 2016 11:55:00 PM.

Décomposition des données

Vous pouvez décomposer les données dans les vues Liste en ajoutant des colonnes d'intervalle ou de répartition d'instances à partir de l'onglet Grouper par.

Tableau 3. Options de Grouper par

Option

Description

Ajouter une colonne de répartition d'intervalle (voir les données pour les paramètres des colonnes)

Sélectionnez cette option pour voir les données des ressources sélectionnées réparties dans des intervalles de temps.

Dans l'onglet Données, sélectionnez Répartition d'intervalle pour configurer la colonne. Vous pouvez saisir une étiquette et sélectionner un intervalle de répartition pour la plage de temps.

Ajouter une colonne de répartition d'instance (voir les données pour les paramètres des colonnes)

Sélectionnez cette option pour voir les données pour toutes les instances des ressources sélectionnées.

Dans l'onglet Données, sélectionnez Nom d'instance pour configurer la colonne. Vous pouvez saisir une étiquette et sélectionner un groupe de mesures pour répartir toutes les instances dans ce groupe. Désélectionnez Afficher la mesure agrégée de non-instance pour afficher uniquement les instances distinctes. Désélectionnez Afficher uniquement le nom de l'instance pour afficher le nom du groupe de mesures et le nom de l'instance dans la colonne de répartition d'instances.

Par exemple, vous pouvez créer une vue pour afficher l'utilisation de CPU en sélectionnant la mesure CPU:0|Utilisation. Si vous ajoutez une colonne de répartition d'instances, la colonne CPU:0|Utilisation affiche l'utilisation de toutes instances de CPU sur des lignes distinctes (0, 1 et ainsi de suite). Pour éviter toute ambiguïté, vous pouvez remplacer l'étiquette de mesure CPU:0|Utilisation par Utilisation.

Ajout d'un filtre

L'option de filtre vous permet d'ajouter des critères supplémentaires lorsque la vue affiche trop d'informations. Par exemple, la vue Liste affiche des informations sur la santé des machines virtuelles. Dans l'onglet Filtre, vous ajoutez une mesure de risque inférieure à 50 %. La vue affiche alors la santé de toutes les machines virtuelles ayant un risque inférieur à 50 %.

Pour ajouter un filtre à la vue, sélectionnez Contenu > Vues dans le volet de gauche. Dans la barre d'outils Vues, cliquez sur le signe plus pour ajouter une vue ou sur le crayon pour modifier une vue sélectionnés. Dans l'espace de travail, sur la gauche, cliquez sur Données et cliquez sur l'onglet Filtre dans le volet principal. Si vous créez une nouvelle vue, complétez les étapes précédentes requises.

Chaque sujet possède une zone de filtre distincte. Pour les sujets Cumul d'alertes, Alerte, et Symptôme, toutes les mesures applicables ne sont pas prises en charge par le filtrage.

Tableau 4. Options d'ajout de filtre

Option

Description

Ajouter

Ajoute un critère à l'ensemble de critères existant. Le filtre retourne les résultats correspondant à tous les critères spécifiés.

Ajouter un autre ensemble de critères

Ajoute un nouvel ensemble de critères. Le filtre retourne les résultats correspondant à l'un des ensembles de critères.

Ajout d'une ligne ou d'une colonne récapitulative à une vue

L'option de résumé est disponible uniquement pour les vues Liste et Résumé. Elle est obligatoire pour les vues Résumé. Vous pouvez ajouter plusieurs lignes ou colonnes récapitulatives et les configurer afin qu'elles affichent différentes agrégations. Dans le volet de configuration du résumé, vous sélectionnez la méthode d'agrégation et les données à inclure ou à exclure des calculs.

Pour ajouter une colonne ou une ligne récapitulative à une vue, sélectionnez Contenu > Vues dans le volet gauche. Dans la barre d'outils Vues, cliquez sur le signe plus pour ajouter une vue ou sur le crayon pour modifier une vue sélectionnés. Dans l'espace de travail, sur la gauche, cliquez sur Données, puis sur l'onglet Résumé dans le volet principal. Si vous créez une nouvelle vue, complétez les étapes précédentes requises.

Pour la vue Liste, la ligne récapitulative affiche les informations agrégées par sujets spécifiés.

Pour la vue Résumé, la colonne récapitulative affiche les informations agrégées par éléments fournis dans l'onglet Données.