La riconfigurazione di Site Recovery Manager non riesce dopo l'aggiornamento di un'istanza di vCenter Server 6.5.x o 6.7.x con un Platform Services Controller esterno a un nodo vCenter Server 7.x incorporato.

Problema

Quando si tenta di riconfigurare Site Recovery Manager dopo un aggiornamento di un'istanza di vCenter Server 6.5.x o 6.7.x con un Platform Services Controller esterno a un vCenter Server con un nodo 7.x incorporato,l'operazione non riesce e si verifica un errore.
ERROR
Operation Failed
A general system error occurred: 22ConfigurationException Failed to configure DR server with the Infrastructure Node services. Reason: Fault cause: lookup.fault.EntryExistsFault

Exit code: 61

Causa

Quando si aggiorna un'istanza di vCenter Server 6.5.x o 6.7.x con un Platform Services Controller esterno a un'istanza di vCenter Server 7.x con un nodo incorporato, l'ID del nome del sito di vCenter Single Sign-On cambia.

Soluzione

  1. Prendere nota del valore di serviceId nel messaggio Error 61.
  2. Accedere con le credenziali di vCenter Server a https://<vCenter_Server_address>/lookupservice/mob/ nel sito protetto.
  3. Passare a RetrieveServiceContent > Invoke Method > ServiceRegistration > Delete method per eliminare serviceId: <serviceId>.
  4. Accedere a Gestione appliance Site Recovery Manager nel sito protetto come amministratore.
  5. Fare clic su Riepilogo, su Riconfigura e seguire le istruzioni visualizzate.
  6. Prendere nota del valore di serviceId nel messaggio Error 61.
  7. Accedere con le credenziali di vCenter Server a https://<vCenter_Server_address>/lookupservice/mob/ nel sito di ripristino.
  8. Passare a RetrieveServiceContent > Invoke Method > ServiceRegistration > Delete method per eliminare serviceId: <serviceId>.
  9. Accedere a Gestione appliance Site Recovery Manager come amministratore.
  10. Nell'interfaccia di Gestione appliance Site Recovery Manager, fare clic su Servizi.
  11. Selezionare il servizio srm-server, fare clic su Arresta e quindi su OK.
  12. Accedere tramite SSH al vCenter Server incorporato aggiornato, eseguire il comando seguente e prendere nota del nome del sito di vCenter Single Sign-On.
    /usr/lib/vmware-vmafd/bin/vmafd-cli get-site-name --server-name localhost
  13. Accedere tramite SSH a Site Recovery Manager, eseguire il comando seguente e prendere nota del valore di db_id.
    echo "select * from pds_solutionuser;" | PGPASSWORD='<password>' /opt/vmware/vpostgres/current/bin/psql -U srmdb -d srmdb -p 5432
    Nota: Password è la password per il database vPostgres incorporato impostato durante l'installazione di Site Recovery Manager.
  14. Eseguire il comando seguente.
    echo "update pds_solutionuser set siteid = 'default-first-site' where db_id =<db_id> ;" | PGPASSWORD='<password>' /opt/vmware/vpostgres/current/bin/psql -U srmdb -d srmdb -p 5432
  15. Accedere a Gestione appliance Site Recovery Manager nel sito di ripristino come amministratore e riconfigurare Site Recovery Manager.
  16. Accedere a Site Recovery Manager nel sito protetto.
  17. Nella scheda Home di Site Recovery, selezionare una coppia di siti e fare clic su Visualizza dettagli.
  18. Selezionare Coppia di siti > Riepilogo e fare clic su Riconnetti.
    1. Se si verifica un errore, riavviare le istanze di Site Recovery Manager e vCenter Server e ripetere l'operazione di riconnessione.
      Unable to connect to Site Recovery Manager Server at https://<SRM FQDN/IP>:443/drserver/vcdr/vmomi/sdk. 
      Reason: java.net.SocketTimeoutException: 30,000 milliseconds timeout on connection http-outgoing-431 [ACTIVE]