Quando si avvia un ripristino o un test di ripristino, alcune SRA inviano risposte a Site Recovery Manager prima che un dispositivo di storage promosso nel sito di ripristino sia disponibile per gli host ESXi. Site Recovery Manager esegue nuovamente la scansione dei dispositivi di storage e tale scansione non riesce.

Problema

Se i dispositivi di storage non sono ancora completamente disponibili, ESXi Server non li rileva e Site Recovery Manager non trova i dispositivi replicati quando ripete la scansione. Ciò può causare diversi problemi.

  • I datastore non vengono creati e non è possibile trovare le macchine virtuali ripristinate.
  • Gli host ESXi smettono di rispondere all'heartbeat di vCenter Server e si disconnettono da vCenter Server. In questo caso, vCenter Server invia un errore a Site Recovery Manager e un ripristino o un test di ripristino non riesce.
  • L'host ESXi è disponibile, ma la nuova scansione e la nuova firma del disco superano i timeout di Site Recovery Manager o vCenter Server generando un errore di Site Recovery Manager.

Causa

I dispositivi di storage non sono pronti quando Site Recovery Manager avvia la nuova scansione.

Soluzione

Per ritardare l'inizio della ripetizione della scansione dello storage finché i dispositivi di storage non sono disponibili negli host ESXi, aumentare il valore dell'opzione storageProvider.hostRescanDelaySec impostandolo su un numero compreso tra 20 e 180 secondi. Vedere Modifica delle impostazioni del provider di storage.