In un ambiente di Site Recovery Manager di grandi dimensioni, è possibile che si verifichino errori di timeout durante l'accensione delle macchine virtuali in un sito di ripristino condiviso.

Problema

Quando si accendono le macchine virtuali in un sito di ripristino condiviso, viene visualizzato il messaggio di errore Errore: si è verificato il timeout dell'operazione: 900 secondi.

Causa

Questo problema può verificarsi se una singola istanza di vCenter Server gestisce un numero elevato di macchine virtuali nel sito di ripristino condiviso, ad esempio almeno 1000.

Soluzione

  1. Aumentare il valore del timeout di remoteManager.defaultTimeout in Site Recovery Manager Server nel sito di ripristino.
    Ad esempio, aumentare il timeout dal valore predefinito di 300 secondi a 1200 secondi. Per informazioni su come aumentare l'impostazione remoteManager.defaultTimeout, vedere Modifica delle impostazioni di Remote Manager in Amministrazione di Site Recovery Manager.

    Non aumentare eccessivamente il periodo del timeout. Se si imposta il timeout su un periodo di tempo troppo lungo, è possibile che altri problemi vengano nascosti, ad esempio i problemi relativi alla comunicazione tra Site Recovery Manager Server e vCenter Server o altri servizi necessari per Site Recovery Manager.

  2. Aprire il file vmware-dr.xml in un editor di testo.
    Il file vmware-dr.xml si trova nella directory /opt/vmware/srm/conf/.
  3. Impostare il timeout per la lettura da vSphere Client.
    Impostare il timeout su 900 secondi (15 minuti) aggiungendo una riga all'elemento <vmacore><http>.
    <vmacore>
      <http>
        <defaultClientReadTimeoutSeconds>900</defaultClientReadTimeoutSeconds>
      </http>
    </vmacore>
  4. Riavviare il servizio Site Recovery Manager Server.

Operazioni successive

Se i timeout continuano a verificarsi anche dopo aver aumentato il valore di timeout di RemoteManager, provare a impostare valori di timeout progressivamente più lunghi.