Il ripristino o il test di ripristino non riesce e si verifica un errore perché l'hardware dell'host e i datastore non sono disponibili se si esegue il ripristino o il test di subito dopo che si sono verificate modifiche nell'inventario di vCenter Server.
Problema
Il ripristino o il test di ripristino non riesce e viene visualizzato il messaggio di errore Non sono disponibili host con versione hardware '7' e datastore 'ds_id' accesi non in modalità di manutenzione..
Causa
Site Recovery Manager Server conserva una cache dello stato dell'inventario dell'host. A volte, quando si verificano modifiche recenti all'inventario, ad esempio se un host diventa inaccessibile, viene disconnesso o perde la connessione ad alcuni dei datastore, Site Recovery Manager Server può richiedere fino a 15 minuti per aggiornare la cache. Se nella cache di Site Recovery Manager Server è presente lo stato dell'inventario dell'host non corretto, è possibile che un ripristino o un test di ripristino non riesca.
Soluzione
Se si modifica l'inventario dell'host, attendere 15 minuti prima di eseguire un ripristino. Se il messaggio di errore viene visualizzato nuovamente, attendere 15 minuti ed eseguire nuovamente il ripristino.