Prima di distribuire vCloud Director Object Storage Extension, è necessario preparare l'ambiente. vCloud Director Object Storage Extension richiede componenti esterni specifici e supporta versioni specifiche dei componenti esterni.

Nella tabella seguente sono elencati i componenti software e le versioni supportate dei componenti che è necessario distribuire e configurare.
Componente obbligatorio Versioni supportate
vCloud Director
  • 10
  • 9.7
  • 9.5
  • 9.1
Nota: Per utilizzare vCloud Director Object Storage Extension, l'istanza di vCloud Director che si usa deve supportare vCloud Director Service Provider Admin Portal e vCloud Director Tenant Portal.
Cloudian HyperStore È necessario un cluster con almeno 3 nodi Cloudian HyperStore.
  • Per vCloud Director Object Storage Extension 1.0.1, installare e configurare Cloudian HyperStore 7.1.6.
  • Per vCloud Director Object Storage Extension 1.0, installare e configurare Cloudian HyperStore 7.1.4.
Per ulteriori informazioni sui requisiti specifici di Cloudian HyperStore, vedere Requisiti di Cloudian.
Database
  • PostgreSQL 10
  • PostgreSQL 9

vCloud Director Object Storage Extension richiede un'istanza di database dedicata e un utente del database che disponga di privilegi sufficienti per creare tabelle e modificare gli schemi del database.

vCloud Director Object Storage Extension non richiede il bus di messaggi RabbitMQ per la comunicazione con vCloud Director.