La procedura guidata di attivazione di NSX Network Detection and Response segnala un errore dopo il tentativo di distribuzione del componente del connettore di NSX Cloud.

Problema

Come parte dell'attivazione della funzionalità NSX Network Detection and Response, la procedura guidata di attivazione tenta di distribuire il componente del connettore di NSX Cloud. Il connettore di NSX Cloud registra l'installazione del NSX con il servizio cloud NSX Advanced Threat Prevention e crea un canale sicuro tra le risorse locali e le risorse cloud. Se durante questi passaggi si verifica un problema, la procedura guidata di attivazione segnala un errore di distribuzione del connettore di NSX Cloud, che blocca il proseguimento dell'attivazione di NSX Network Detection and Response e causa alla fine il timeout.

Causa

Il connettore di NSX Cloud stabilisce la connettività con la regione del servizio cloud di NSX Advanced Threat Prevention selezionata e attiva la registrazione utilizzando le licenze di NSX. Se la connessione non è disponibile, la registrazione non riesce o si verifica un timeout.

Soluzione

  1. Il connettore di NSX Cloud utilizza lo stesso canale di comunicazione precedentemente convalidato durante la verifica preliminare dell'attivazione di NSX Network Detection and Response. Se la configurazione di NSX è cambiata tra l'esecuzione della verifica preliminare di NSX Network Detection and Response e l'attivazione effettiva di NSX Network Detection and Response, eseguire nuovamente la verifica preliminare dell'attivazione. Se si verifica un errore, seguire le informazioni sulla risoluzione dei problemi relativi all'errore di verifica preliminare dell'attivazione.
  2. Assicurarsi che NSX Application Platform sia distribuito correttamente e sia indicato come STABILE nella pagina dell'interfaccia utente Sistemi > NSX Application Platform.
  3. Esaminare i registri per il servizio di registrazione del connettore di NSX Cloud.
    1. Raccogliere un bundle di supporto di NSX Application Platform e analizzare i registri per cercare un pod Kubernetes con il nome che inizia con cloud-connector-register.
    2. In alternativa, è possibile eseguire query interattive sui registri nell'appliance NSX Manager attenendosi alla procedura seguente.
      1. Accedere all'appliance NSX Manager come root.
      2. Utilizzare il comando seguente per contrassegnare la configurazione di Kubernetes per tutte le chiamate helm e kubectl successive.
        export KUBECONFIG=/config/vmware/napps/.kube/config
      3. Utilizzando il comando seguente, verificare che il grafico Helm del connettore di NSX Cloud sia distribuito correttamente.
        helm --namespace nsxi-platform list --all --filter 'cloud-connector'
        Verificare che la proprietà STATUS indichi distribuito.
      4. Verificare che il pod di registrazione sia distribuito e completato correttamente.
        kubectl --namespace nsxi-platform get pods --selector='job-name=cloud-connector-register'
        Il pod deve mostrare STATUS come Completato.
      5. Esaminare gli eventi per il pod di registrazione, utilizzando il comando seguente.
        kubectl --namespace nsxi-platform describe pod --selector='job-name=cloud-connector-register'
        
        La sezione Eventi fornisce lo stato del processo di registrazione e le azioni associate al processo.
      6. Utilizzare il comando seguente per analizzare i registri per verificare la presenza del pod di registrazione.
        kubectl --namespace nsxi-platform logs --selector='job-name=cloud-connector-register' --container=main
  4. Dopo aver risolto l'errore, fare clic su Azioni nella scheda della funzionalità NSX Network Detection and Response. Selezionare Elimina per avviare l'eliminazione della funzionalità di NSX Network Detection and Response parzialmente attivata. Al termine del processo di eliminazione, riprovare l'attivazione della funzionalità.