Si è verificato un errore durante la distribuzione della funzionalità Metriche NSX mentre il sistema tentava di distribuire il database Postgres.

Problema

Si è verificato un problema nel sistema durante il tentativo di distribuzione del database Postgres utilizzato dalla funzionalità Metriche NSX.

Causa

Esistono diverse motivazioni alla base della mancata riuscita della distribuzione del database Postgres delle metriche.

Soluzione

  1. Assicurarsi che il sistema abbia distribuito NSX Application Platform correttamente.
  2. Se si dispone dell'accesso all'interfaccia della riga di comando (CLI) di NSX Manager, utilizzare i passaggi seguenti per analizzare gli eventuali errori registrati nei registri di Metriche NSX. Se non si dispone dell'accesso alla CLI di NSX Manager, utilizzare le informazioni fornite nel passaggio 3.
    1. Accedere all'appliance di NSX Manager come utente root.
    2. Contrassegnare la configurazione del cluster TKG nel supervisore o Kubernetes upstream per qualsiasi richiamo successivo dei comandi helm e kubectl.
      export KUBECONFIG=/config/vmware/napps/.kube/config
    3. Utilizzare il comando seguente per verificare che il sistema abbia distribuito correttamente il grafico Helm delle metriche.
      helm --namespace nsxi-platform list --all --filter 'metrics'

      La proprietà STATUS deve mostrare distribuita.

    4. Usare il comando seguente per verificare che i pod di configurazione siano stati distribuiti e completati correttamente.
      kubectl --namespace nsxi-platform get pods --selector='app.kubernetes.io/instance=metrics,app.kubernetes.io/name=postgresql-ha'
    5. Usando il comando seguente, ispezionare i registri per individuare i pod di configurazione che non sono stati distribuiti o non si trovano nello stato Pronto.
      kubectl --namespace nsxi-platform logs <POD_NAME>
  3. Se non si dispone dell'accesso alla CLI di NSX Manager, raccogliere il bundle di supporto di NSX Application Platform utilizzando le informazioni in Raccolta dei bundle di supporto per NSX Application Platform utilizzando l'interfaccia utente. Esaminare i registri del bundle di supporto per i pod del cluster TKG nel supervisore o Kubernetes upstream il cui nome inizia con metrics-postgresql-ha.
  4. Risolvere gli errori riportati nei registri.
  5. Dopo aver risolto gli errori segnalati nei registri, provare di nuovo a distribuire NSX Application Platform utilizzando l'interfaccia utente di NSX Manager.